Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When ever I install XAMP I get this message

alt text

everything works fine but there is this message every time I install.

share|improve this question
    
are you using skype? if yes, stop it and try again. –  Paul Aug 1 '10 at 18:26
add comment

5 Answers

That means so other software is already listening to port 80 or 443 could be skype or iis shut that down then run the installer again,

share|improve this answer
    
i aint using IIS or Skype.... i walways get this message whenver i install –  user38257 Aug 2 '10 at 4:42
add comment

Use use netstat -ao |find /i "listening" to find what process id is listening to the port, then use your task manager to see what process it is and stop it.

share|improve this answer
add comment

I assume this is a linux box, if so try sudo netstat -lnp |grep :80. It should let you know what process is using port 80. Based on the Process ID you should be able to further investigate if necessary. ie ps aux |grep <process id>

Replace <process id> with whatever number netstat tells you :)

share|improve this answer
    
ahn... am at XP –  user38257 Aug 2 '10 at 9:37
add comment

Use tcpview to see what process opens port 80 or 443.

share|improve this answer
add comment
up vote 0 down vote accepted

All you need to do is Add Port Exceptions in your Windows Firewall Settings for port 80 & 443

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.