Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

https://localhost works but https://ipaddress didn't

cat logs/ssl_error_log

[Mon Aug 02 19:04:11 2010] [error] [client 192.168.1.158] (13)Permission denied: access to /ajaxterm denied
[root@space httpd]# cat logs/ssl_access_log
192.168.1.158 - - [02/Aug/2010:19:04:11 +0530] "GET /ajaxterm HTTP/1.1" 403 290
[root@space httpd]# cat logs/ssl_request_log
[02/Aug/2010:19:04:11 +0530] 192.168.1.158 SSLv3 DHE-RSA-CAMELLIA256-SHA "GET /ajaxterm HTTP/1.1" 290 

httpd.conf file

NameVirtualHost *:443
<VirtualHost *:443>
    ServerName localhost
    SSLEngine on
    SSLCertificateFile /etc/pki/tls/certs/ca.crt
    SSLCertificateKeyFile /etc/pki/tls/private/ca.key

    <Directory  /usr/share/ajaxterm >
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
        Allow from All
        </Directory>
        DocumentRoot  /usr/share/ajaxterm
    DirectoryIndex ajaxterm.html

       ProxyRequests Off
       <Proxy *>
#               Order deny,allow
               Allow from all
       </Proxy>
       ProxyPass /ajaxterm/ http://localhost:8022/
       ProxyPassReverse /ajaxterm/ http://localhost:8022/

    ErrorLog error_log.log
    TransferLog access_log.log
</VirtualHost>

How to fix this ?

share|improve this question
add comment

2 Answers

Change your Order directives to be

Order deny,allow

And that's it. No other lines. Take out the Allow from lines. You can tune those later.

If that does not help, you might have something else blocking the access around your httpd.conf.

share|improve this answer
    
in the <Directory> section you want me to align the "Order" directive? Or you want to uncomment "Order" directive?Thanks. –  lakshmipathi Aug 3 '10 at 7:07
    
In both <Directory> and <Proxy> sections make it ONLY contain the Order directive (being Order deny,allow) and comment out the Allow lines. –  Janne Pikkarainen Aug 3 '10 at 7:16
    
oops ..no luck . I changed it and commented out Allow line ..even that didn't help :( –  lakshmipathi Aug 3 '10 at 7:37
    
Perhaps you have SELinux enabled and it's doing the blocking? Try command getenforce and if it returns enforcing, enter setenforce 0. –  Janne Pikkarainen Aug 3 '10 at 8:10
    
getenforce says SELinux is disabled.Is there is anything else I need check for example file permission and file owners ? ls -l /usr/share/ajaxterm/ total 292 -rwxr--r-- 1 apache apache 1557 2009-07-24 20:33 ajaxterm.css -rwxr--r-- 1 apache apache 1963 2010-07-25 19:26 ajaxterm.html -rwxr--r-- 1 apache apache 8565 2010-07-24 00:43 ajaxterm.js –  lakshmipathi Aug 3 '10 at 9:04
show 1 more comment

Hi please do change in following lines

Options FollowSymLinks
    AllowOverride all
    Order allow,deny
        Allow from All

It will working after these changes in apache configuration files

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.