Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an Exchange 2007 server running and have had no issues since it's installation, until now.

There are about 80 Email accounts and the server has a 500GB Hard drive, with about 12GB of free space.

We are now not receiving any emails, they are sitting on our web server in a queue and the Exchange server event viewer is saying Insufficient system resources (Event Viewer error 15006), I've done a search and found this post.

I've not currently got the ability to change the location of the logs, so I thought it might be possible to clear the log instead? - However, I can't find any details on this.

I have however, disabled 'Back Pressure' but we are still not receiving emails.

Does anyone have any suggestions?

share|improve this question
    
any other errors in the event log? –  Jim B Aug 3 '10 at 14:57
    
What version of Exchange? –  DanBig Aug 3 '10 at 16:43
    
No other errors referring to Exchange. It's sat on an SBS 2008 box. It's version 2007. –  MikeT505 Aug 3 '10 at 16:59
    
@Mike, Standard or Enterprise? How big is the current mail store database? –  DanBig Aug 3 '10 at 17:07
1  
If you open the Exchange Management Console, expand Server Configuration on the left, then Mailbox. In the bottom of the main window, it will show you your storage groups. Note the path and browse to it. The .edb file is what you are looking for. –  DanBig Aug 3 '10 at 17:16

2 Answers 2

up vote 1 down vote accepted

Alleviate your free disk space problem and your email reception problem will go away. Anything else is just going to set you up for an even bigger mess when you completely fill the disks on the server computer.

Are you doing online backups of Exchange? I have a sneaking suspicion that you're not, and you're building up Information Store database transaction logs. If you don't know where to look, open the "Exchange Management Shell" and (assuming you left your mailbox store in the default "First Storage Group"): get-storagegroup "First Storage Group" | format-table -Property LogFolderPath

You should only have ".LOG" files in that directory back to your last full online backup. If you're seeing a large number of ".LOG" files in that directory and, particularly if they're old, then you're probably not performing full online backups.

The "right solution" to that problem is to perform an online full backup. Anything else (switching the database logging mode to circular, performing a rebuild on the information store databases, etc) is a "hack" and isn't solving the problem in the way that Microsoft recommends.

Edit:

Your WSUS directory is awfully big, but depending on the products and languages you have selected it's perfectly possible that it would be that big.

It sounds, to me, like you just need more disk. I'm assuming the rest of your space usage on the disk is in shared folders / files. Is there something there you can remove / relocate temporarily?

You could move the queue database to another disk. You say you've disabled back pressure, but you're still not receiving email. Double-check your procedure to disable back pressure and see that you really have disabled it and restarted the Transport service.

share|improve this answer
    
Hey - No we're not doing online backups, we're using the SBS 2008 backup system to backup to an external hard drive. - So surely this would clear the logs? –  MikeT505 Aug 5 '10 at 17:44
    
The built-in backup in Windows Small Business Server 2008 is supposed to be Exchange-aware. So, are you seeing buildup of transaction log files, then? If so, then you may have a problem with the Exchange-aware VSS writer. –  Evan Anderson Aug 5 '10 at 18:41
    
Hi Evan - No nothing unusual, nothing in Event viewer mentioning backup issues - Any suggest as to how I could locate them? –  MikeT505 Aug 5 '10 at 21:44
    
@MikeT505: Just so I'm clear, though, you have determined that transaction log files building up is the cause of your low disk space condition? –  Evan Anderson Aug 5 '10 at 21:55
1  
@MikeT505: You didn't post the exact error you're seeing in the event log, but it's likely low free disk space is the culprit if your error is similar the bit.ly link. You're over 90% allocated on disk! I'd run the WSUS Server Cleanup Wizard (technet.microsoft.com/en-us/library/cc708578(WS.10).aspx) and see what space that gets back. IIS log files are another culprit disk space usage on SBS machines blogs.technet.com/b/sbs/archive/2008/02/28/…) so have a look there, too. It sounds like you may just need more disk. –  Evan Anderson Aug 5 '10 at 22:50

https://www.jam-software.de/customers/downloadTrial.php?article_no=80&language=EN&PHPSESSID=1f31a91f79d156a177fcbe2dd7110e71

http://www.jam-software.com/treesize/

Download the above utility on your server and run it, this will help you in getting rid of files in directories you may not know.

If you are running a backup application to backup Exchange, make sure it is truncating logs (backup app should be exchange aware) - if not, then download a trial of Backup Exec System Recovery 2010 (it is exchange aware, flushes logs, does baremetal restores etc

http://www.symantec.com/business/backup-exec-system-recovery-server-edition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.