Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi in my development machine I want to completely turn off caching (all types) for php. No matter what I try IIS 7 is still caching and it really drives me crazy!

share|improve this question
add comment

2 Answers

OK, this may be a late response, but i had a similar problem, that it turns out was caused by a PHP accelerator called wincache.

just comment out this line in php.ini [PHP_WINCACHE] ;extension=php_wincache.dll

share|improve this answer
add comment

Check if you have the below mentioned entry in your applicationHost.config file.

<system.webServer>
    <caching enabled="true" enableKernelCache="true">
    </caching>
</system.webServer>

Change the true to false and you should be good..

From UI,

Click on the Web Site -> Output Caching click on Edit Feature Settings... uncheck Enable cache and Enable kernel cache

share|improve this answer
    
both unchecked and set to false, still caching. my php file is so simple it just echo "somestring" but still caching about 1 minute. –  user50154 Aug 4 '10 at 10:23
    
if those parameters are false.. then i would check if PHP caching is enabled in the application.. check this article blogs.iis.net/bills/archive/2006/10/31/PHP-on-IIS.aspx –  Vivek Kumbhar Aug 4 '10 at 12:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.