Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The instance I choose was the following:

Basic 64-bit Microsoft Windows Server 2008 (AMI Id: ami-d9e40db0)
Microsoft Windows 2008 R1 SP2 Datacenter edition and 64-bit architecture.

I have installed Tomcat + an application and AM able to see the website when I access the local IP thru IE (in the EC2 instance).

However, when I try accessing it as:

* the assigned Elastic IP
* the

from the EC2 instance itself or from outside, it doesn't work. IE says: Internet Explorer cannot display the webpage

I've tried:

* disabling the Firewall -> no luck
* waiting for a bit -> no luck

I can't ping the machine assigned Elastic IP either.

The allowed connections (as seen in Amazon's Management Console) is as:

Connection Method  Protocol From Port     To Port   Source (IP or group)
SSH              tcp               22          22
RDP              tcp             3389        3389
DNS                 tcp            53          53
DNS                 udp            53          53
HTTP                tcp            80          80
share|improve this question
up vote 1 down vote accepted

I figured it out... I wasn't disabling ALL of the Windows Firewalls!!

There are 3 in Windows Server 2008

Domain Profile

Private Profile

Public Profile

Disabling in each made it work... of course, at production time I will set these appropriately...

share|improve this answer
Can you please provide the details how did you do this ? – mprabhat Jun 11 '12 at 7:14

You shouldn't be disabling your firewall. This would compromise the security of your app and server VM. Instead modify the windows server inbound firewall rules to allow incoming traffic on specific ports.

I encountered a similar issue with windows server 2012. I addition to having the correct security group settings, you also have to manually modify the firewall rules on the windows server.

I have documented both security group settings and firewall rules here:

Note: its likely that your settings for your prod environment would be even more strict than the ones listed at the webpage available at the link.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.