Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up a Sympa list serv server and everything is working fine for the most part. One issue that I am running into is sending files over ~580 KB in size (just a normal .txt file) are not going through. I am getting the following error.

Impossible to distribute your message for list 'list-name' because of an internal server error.

I have verified that my "Maximum message size (max_size)" setting in Sympa is get to 5 MB so that shouldn't be the problem. If I try sending the same .txt file after taking out a few lines, and the file size is ~530 KB, then it works just fine. Any help would be greatly appreciated.

share|improve this question
    
Do you have some interesting logs in Sympa ? –  Dom Aug 5 '10 at 7:41
    
Nothing that's really jumping out to why that error is occurring. –  user22492 Aug 5 '10 at 13:03
add comment

2 Answers 2

I'd say this has something to do with php settings variables upload_max_filesize and memory_limitphp. They're normally somewhere in php.ini, depending on your OS and Webserver.

share|improve this answer
    
Sympa is written in Perl, not PHP. I don't know anything about upload limits in Perl, but I'd be willing to guess you're right about there being an upload size limit somewhere. –  kaerast Aug 5 '10 at 12:36
    
Oh, hmm, you're right, I'm confusing sympa and phplist. –  Jasper Aug 5 '10 at 12:46
    
It could be, but the only real "max file size limit" setting I see is the one I mentioned in the original post and it is set to 5 MB. The entire email including the .txt file attachment is less than 1 MB. –  user22492 Aug 5 '10 at 13:13
add comment
up vote 0 down vote accepted

Got it fixed.

It was a problem with the database not being able to handle the packet size. I had to manually edit the /etc/my.cnf file and bump up the max_allowed_packets size and then restart mysqld.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.