Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am manually dialing remote machines using my serial modem via the linux command line. I am automating the process, hence not using any dialing tools (I've already tried most of them - none are sufficient).

I can make connections successfully - however when I turn on the verbose option on my modem ("AT V1"), the output and input of my device seems to be interspersed with excessive newlines. I'm sending commands to my modem with "echo 'command' > /dev/ttyS0", then listening on another terminal with "cat /dev/ttyS0". The newlines steadily increase in number, and are also sent to the serial connection, making it impossible to enter a username or password, or any other data. Eventually the connection is terminated due to multiple failed login attempts.

I captured the entire sequence as an example and pasted it here: http://pastebin.com/j8Fc236m

share|improve this question
    
How is your serial port configured? Is this an external modem? Are you running getty or similar on that port? Have you read the HOWTO? Which dialers have you tried and what problems did you have? –  Dennis Williamson Aug 5 '10 at 5:09
    
Thanks for the suggestions - your first was the key - I hadn't configured my port correctly. –  tjbp Aug 5 '10 at 11:18

1 Answer 1

Check "man stty" and investigate various character conversion settings.

share|improve this answer
1  
Please add the particular configuration change that fixed this problem. It may be useful to someone who comes along later and has a similar problem. –  Dennis Williamson Aug 5 '10 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.