Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install a Perl program, but its minimum version requirement is Perl 5.10.0. We are running CentOS 5.5, which has Perl 5.8.8 as the default.

Is there an easy way to upgrade Perl to 5.10.* so I can get this module installed?

I am new to both CentOS and Perl so I don't know where to start...

share|improve this question

1 Answer 1

up vote 3 down vote accepted

While CentOS 6 will have Perl 5.10.* supported (see the list of included packages for Red Hat Enterprise Linux 6), there are not many RPM sources for installing 5.10.x on CentOS 5. Your best bet will be to compile it yourself.

To do that, you can download any version from 5.3 to the latest development version (5.13) from CPAN - you can download it directly from here.

Download, extract, configure if you want to support specific features, and run make, make test, and make install. See the installation page for Perl at CPAN here for a walkthrough (You can also see a basic tutorial for installing 5.10 this way at this site).

share|improve this answer
    
Awesome, thank you. I have downloaded 5.12.1, and done the make, make test, and make install steps. However, it has installed next to 5.8.8. So I now have 'perl' and 'perl5.12.1' as executables... how can I make perl load the perl5.12.1 version? –  Valorin Aug 5 '10 at 4:26
1  
I just used symlinks to replace /usr/bin/perl with the 5.12.1 version. It appears to have done the trick. –  Valorin Aug 5 '10 at 4:35
5  
I wouldn't actually change the /usr/bin/perl link. Perl tends to get used under the hood for a lot of things, due to it being installed by default on almost every modern *nix. Changing the /usr/bin/perl symlink to point to a different version than your OS/distribution vendor provides comes with a small risk of breaking things. Now, Perl does a better job at backwards compatibility than most, but it's still a risk. You're better off just writing a wrapper for your application, or explicitly telling the app that needs the newest version to use /usr/bin/perl5.12.1 instead of /usr/bin/perl. –  Christopher Cashell Oct 19 '10 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.