Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This is installed on CentOs 5.5

Please bare in mind that this is on a local network at work and access from the outside world is not possible due to the strict restrictions on the local network.

I have managed to get php 5.3 installed on the linux box, however I am having great difficulty in setting up phpmyadmin, no matter what I do I can't get it to work.

phpMyAdmin is in /usr/share/phpMyAdmin and I have an Alias in phpMyAdmin.conf which is called into the httpd.conf file.

This is the Alias's that I am using:

Alias /phpmyadmin "/usr/share/phpMyAdmin"
Alias /phpMyAdmin "/usr/share/phpMyAdmin"
Alias /mysqladmin "/usr/share/phpMyAdmin"

I have warn you that I only really started using ssh for the last 2 days so I am a linux newbie.

I appreciate any help I can get.

Thanks in advance, Jon

share|improve this question
    
what happens when you try to access phpmyadmin page ? it prints php ? it reply with a 500 error ? have you done yum install phpmyadmin ? also have you tried any simple php page to see if your php installation was succefull –  Prix Aug 5 '10 at 9:52
    
By trying to access the ip_here/phpmyadmin I get the following error... You don't have permission to access /phpmyadmin on this server. I have tried yum install phpmyadmin and it won't install because of dependencies which I can't find a repository for. The PHP works as I can output phpinfo on a .php page. Thanks –  jonraw Aug 5 '10 at 9:59

4 Answers 4

Maybe "/usr/share/phpMyAdmin" was created by root user and apache user can't access it.

As root type:

chown -R apache.apache /usr/share/phpMyAdmin
service httpd restart
share|improve this answer
    
This is something that I have tried, and still not helped... Apologies for not adding that to my question :( –  jonraw Aug 5 '10 at 10:23
    
Did you restart apache service? What returns ls -ld /usr/share/phpMyAdmin? –  lg. Aug 5 '10 at 10:27
    
I did restart apache and this is what it returned drwxr-xr-x 11 apache apache 4096 Aug 5 10:52 /usr/share/phpMyAdmin –  jonraw Aug 5 '10 at 10:28
    
What does tell Apache logs? /var/log/httpd/error.log or /var/log/messages (grep httpd) –  lg. Aug 5 '10 at 10:50
    
Instance of the error in error_log is: [Thu Aug 05 12:02:26 2010] [error] [client 192.168.1.94] (13)Permission denied: access to /phpMyAdmin denied –  jonraw Aug 5 '10 at 11:05

Try to look into your phpMyAdmin.conf if you have something like this:

<Directory/usr/share/phpMyAdmin>
order deny,allow
deny from all
allow from 127.0.0.1
</Directory>

That would actually say that you cannot access phpMyAdmin from a remote computer, I would remove that bit and test first and then let us know if that work or not.

share|improve this answer
    
This isn't in my .conf file, only the 3 Alias's mentioned above are in there. –  jonraw Aug 5 '10 at 11:08
    
I just tried this: <Directory /usr/share/phpMyAdmin> order deny,allow allow from 127.0.0.1 allow from 192.168.1.94 </Directory> –  jonraw Aug 5 '10 at 11:14

Something is set in your httpd.conf that is not allowing the alias to resolve correctly. Other than that, try adding a trailing slash to the URL: http://localhost/phpmyadmin/

share|improve this answer
    
In fact, upon checking directly on the server itself, you can't even access phpmyadmin via localhost... Now I am truely baffled. Trailing slash didn't work.. I guess I need to filter through the entire httpd.conf but I am unsure what I would be looking for to be honest. –  jonraw Aug 5 '10 at 11:22
up vote 0 down vote accepted

UPDATE

I have now managed to get it working on the localhost, so I guess now I just need to get it working from a remote machine.

share|improve this answer
    
Fixed the problem now... I uninstalled all instances of php / mysql / phpmyadmin, reinstalled... Set the owner of phpmyadmin to apache.apache changed the phpMyAdmin.conf to allow from all and everything seems to be working now. Thanks everyone for the help, but I have now managed to work it now. –  jonraw Aug 5 '10 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.