Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need your help explaining this one. The other day I was notified that someone had unplugged one of our IP phones and it wouldn't come back up. As the day progressed, more and more phones started dropping off the network.

My network is setup with data on vlan1 and voice on vlan10. 3com switches (5500,2426,2928.)

Other network details are similar to this other post: Serverfault - voip phone issue

* The phone system uses a separate vlan from the computers (of course).
* Each phone shares a wire with the computer at the desk (the computers plug into the back of the phone). That's typical from other environments I've seen.
* The phones vlan is on a completely different subnet than the default vlan. I mean, 192.168.xx vs 10.x.x.x, so it's not even close. Addresses for both networks are served from a single Windows Server 2003 dhcp server, with a different zone for each vlan.

The problem is that the phones can't get a valid ip address. They keep getting an address from the other subnet (192.168.xx).

So I Poured over the switches and verified that their vlan and port configuration is correct, and it was. The next step was to start isolating switches from the network. Once my dhcp server (windows 2008r2) was removed from any of the switches, the phones would get an ip from the pbx and go on their happy way.

The 2008r2 box is a Dell PE1950, with broadcom network drivers (vers 5.2.14.0) which apparently is vlan aware. In the braodcom control suite there is an option "Priority & Vlan" which is enabled by default. This setting is tied to the "Vlan ID" option which id 0 by default. After disabling the "Priority & Vlan" setting, all the phones started getting their correct ip.

So everything appears to be normal until the next day... Suddenly random computers are no longer able to get to the internet or local network resources. (First noticed by the mac's on the network.) On all the computers, they were being handed out an IP address but incorrect dns info. (It was passing the opendns dns servers, not my local dns server address, or in one case the dns was set to the dhcp server ((which is also a dns server)). So this all leads back to my dhcp server.

My dhcp server (the windows 2008r2 box from above) was recently added to the network. The scope was setup EXACTLY like the server2003 box it was replacing. The correct dns servers were listed in the scope options. (Also tried to move them to the server options, with no luck...) The server was authorized and the scope was activated. I tried reinstalling dhcp on the server only to end up with the same issues.

So I finally decided to bring my 2003 server back online as the dhcp/dns server. Once it as in place and the 2008r2 server was disconnected, all my issues disappeared.

Questions: 1) Have you ever seen this happen before? 2) Did something dramatically change in 2008r2 with the dhcp/dns server? 3) Why did the PE1950 respond to dhcp requests on multiple vlans? 4) What would keep my dhcp server from handing out the correct dns information? [it was configured correctly]

Thanks for any help/insight.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I think you are going to need to configure your broadcom driver differently. You should have two separate "virtual" network cards and then the physical network card on the 2008 server. Each virtual should have it's own VLAN configured. This will happen automatically once you configure the broadcom driver to have two VLANs. A reboot will be required after this (at least on my Win7 machine it was). The physical network card is really not used by the OS anymore, the virtuals are.

After you set this up, then bind your DHCP scopes to the appropriate "virtual" network card based on the VLAN desired for each scope and you shouldn't have anymore problems.

share|improve this answer
    
Thanks. You confirmed that I was heading in the right direction. –  hydrox467 Aug 6 '10 at 4:10
    
You're welcome. good luck –  Scott Lundberg Aug 6 '10 at 13:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.