Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm configuring a Windows Server 2k8 for the first time ever and it comes with 2 300GB HDDs. The problem is, the secondary would be D drive is not available in explorer. It shows up under the storage manager and Speccy also sees it, so it does exist. I can't assign it a drive letter either. There's no RAID setup, so that isn't the issue.

Anyway, I will really appreciate any suggestions on how to fix this issue.

Thanks in advance!

UPDATE

Both drives show up in Device Manager. Type: Healthy (Active, Primary Partition); State: Online.

UPDATE/CONCLUSION

So, I figured it out, but I was just screwing around. Apperantly there was a volume setup on it which was pretty much a ghost. At first I wasn't sure if I should touch it or not, but then I decided since there was no data to loose since I can't access it, I might as well click on my only available option, which was to delete the volume. Thus the drive became "Unallocated" and I was able to create a new simple volume and now I'm able to use it.

So, for anyone having issues like these, just hit the delete button and start from scratch. In my case this was caused by laziness on whoever provisioned my server at GoDaddy. They just imaged it and left it as it was without fixing the drive.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

There could be many issues or none..I think you have to specify some more details :-)

In storage management you can see type (primary/extended/unallocated) and state (online, offline,...) of the second HD.

Can you describe what you see about the second hdisk?

Have you tried right-clicking and selecting 'format..' or 'Create volume...'?

share|improve this answer
    
The state of the drive is: Online, Healthy (Active, Primary Partition) and all I get when I right click on it is "Delete Volume" –  Alex Aug 5 '10 at 18:43
    
I'll give you the points because you were the closest on suggestions. –  Alex Aug 6 '10 at 4:47

Does it show up in the Device manager and have you tried "Scan for hardware changes?"

I find that Scanning For Hardware Changes can help when USB keys don't automatically mount.

share|improve this answer

Have you created a volume (partition) on the drive in storage management? If not, you'll need to do that before the drive will be assigned a drive letter and before it shows up in Windows Explorer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.