Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using FTP 7.5 created virtual directory, gave user write permission under FTP for that directory. User logs in fine see everything however user can not upload any files. Keeps saying user does not have permission but they do in FTP. I have tried everything I know inclduing giving user permission on the directory itself. ISA 2006 in front of server I unchekced the READ box so I think that is OK (Publishing Rule) ANY HELP WOULD BE APPRECIATED.

RTW

share|improve this question

2 Answers 2

OK anyone who has had this problem I have one solution.

After days with engineers I found the real problem as expected it was in ISA 2006

Yes, you need to create a publishing rule and uncheck the READ box.

However if you are on an EDGE configured firewall one problem may exist. EDGE when created creae an Unrestricted Access Rule take a look you will see it. It looks harmless right. NO

Now right click on the rule you will see another configure ftp click on it.

Uncheck the read box here.

Save

Your done you will be able to upload and download just fine.

Many thanks to Robert McMurray of Microsoft he helped me greatly.

I did some tests afterwords like remove the orgininal publishing rule then I couldn't log in. So I put it back in everything works fine.

So people out their with an EDGE ISA2006 configuration I would check this out.

share|improve this answer

ISA Server has an application-level FTP filter which will by default block any upload, regardless of the actual server settings and user rights. You need to disable it.

You can do that by right-clicking on your FTP publishing rule and selecting "Configure FTP", then de-selecting "Read Only".

share|improve this answer
    
I have deselected "Read Only" already does not work. –  rtwPhoenix Aug 6 '10 at 0:02
    
Do I need to reboot the ISA server HUM will try that now. –  rtwPhoenix Aug 6 '10 at 0:03
    
No, you only need to apply your changes when configuring something in ISA; the problem must be related to the FTP server itself, then. Also, to rule out ISA issues, you can try connecting to your server from inside your network. –  Massimo Aug 6 '10 at 4:37
    
I can connecty internally tried to mkdir and received 550 error, however I can download and see the files in the directory. WS2008 has the firewall turned off. –  rtwPhoenix Aug 6 '10 at 11:47
    
I tried with administrator login could not mkdir same 550 error. –  rtwPhoenix Aug 6 '10 at 11:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.