Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have used mysql happily for years; however, due to certain software requiring SQL Server, I am now evaluating SQL Server 2008.

When I am setting up the previously mentioned program it is giving me the following error:

Default Data/Log location not set on 'VISUALTHUNDERPC' To fix this manually, follow these steps:

  • Connect to the server using SQL Server Management Studio
  • Right click on the server connection and open the Properties
  • Go to the Database Settings page and find the Database default locations
  • Set these values to your desired location

Note: If you would like to keep the default location, you need to change it to something else, save it and then change it back; otherwise SQL Server won't register these locations correctly.

So I open up SQL Management Studio and see the following in the database properties:

http://imgur.com/0aaKQ.jpg

I then set it to some of my own settings and press ok:

Screenshot 2: (Ok, so since I have less than 10 reputation here I can't post more than one hyperlink, but you get the idea...)

After doing this, the program still gives me the same error! I go back into SQL Management Studio and see that my settings have been changed back. The directories do exist (I created them). I've tried setting them to the same directory, different directories, etc... but it just keeps going back to what was in the first screenshot and it keeps giving me the same error!

Am I missing something? Am I doing something wrong? What is wrong with the default directories anyway (why bother having them there?)?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Taking a stab in the dark here, but check that process you are running sql server as has enough permissions on those default directories? This should have been setup when you did the install, but something may have gone wrong.

You may also want to try running SSMS as administrator (looks like your running windows7/vista) & see if the problem goes away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.