Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm evaluating the ability of SharePoint to meet the document management needs of my team. I'm running into some issues that make it feel very "clumsy," and believe it may be due to an incorrect configuration.

In general, whenever I open a Word document that's stored in SharePoint, it asks for my credentials. If I check the box to remember my credentials, it only does so until the next time Word is closed and reopened. As a result, for most operations I am asked to enter my password for every document I open, which is extremely frustrating. If I open the document via SharePoint Workspace (Groove renamed for 2010), I find that if I click Cancel at the credentials box, the document will open but is Read Only. To edit the document, I must put in my password when the document is opening. If I open the document via the web interface or via Windows Explorer, then I can hit Cancel and the document can be edited.

For SharePoint to not drive me insane, I need it to behave as follows:

  • If I choose to remember my credentials, do so.
  • Automatically open as editable when I open it via Explorer or SharePoint workspace.
  • The web interface asks if I want to open it read-only or editable - it should perform the selected action.

Server Software: Server 2008 R2, SharePoint server 2010
Client Software: Windows 7 x64, Microsoft Office 2010

Since I can't add comments: @Michael Stum: The same behavior occurs.

share|improve this question
    
Are all users/machines on the same domain? Are you using IE? Sorry for the simple questions. –  USACASD Aug 6 '10 at 22:34
    
The client computer is not a member of the domain. The user is logging in using their domain credentials, which differ from the local computer. We are using IE. –  280Z28 Aug 6 '10 at 22:56
    
Ideally, all users and systems would be a part of the domain. Authentication in MS's single sign-on domain environment usually works nicely. Did you try domain\username and password? –  USACASD Aug 6 '10 at 23:55
add comment

2 Answers 2

  1. Ensure that your SharePoint server is already in the Trusted Sites or Local Intranet security zone in IE.
  2. Ensure that your credentials for the site are stored in Credential Manager (called "Stored User Names and Passwords" in Windows XP) with Enterprise persistence.

If you're still getting prompted for your credentials:

  1. Tools menu > Internet Options
  2. On the Security tab, click the zone your SharePoint server is in (Trusted Sites or Local Intranet) and then click Custom level.
  3. Scroll to the bottom; under User Authentication > Logon, select Automatic logon with current user name and password and click OK. Quit all open Office apps and try opening documents from SharePoint again, and it should not prompt you anymore.
share|improve this answer
add comment

Make sure your SharePoint Server is listed in Trusted Sites or Local Intranet in Internet Explorer. This is assuming it is actually in the internal network.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.