Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I set up cups and avahi on FreeBSD 8.0. However cups printer does not shows in avahi-browse -a on client (other things like ssh server are shown). Additionally if I try to run avahi-browse -a on server it does not succeed:

# avahi-browse -a
Failed to create client object: Daemon not running

CUPS is built with avahi support. Dbus is running. Cups have sharing enabled in web interface.

share|improve this question
    
What exactly are the lines in cupsd.conf which configure BrowseRemoteProtocols and BrowseLocalProtocols? What are the other Browse*...-Settings? (I.o.w.: grep Browse /etc/cups/cupsd.conf results). There should appear a dnssd in the results... Next, set LogLevel debug2 (and revert back after you're finished testing), restart cupsd, and then grep -iE '(dnssd|dns_sd)' /var/log/cups/error_log. –  Kurt Pfeifle Aug 8 '10 at 9:51
    
Here's a (still unresolved) bug regarding avahi support in CUPS' tracker: cups.org/str.php?L3066 -- and here's one in Ubuntu's tracker: bugs.launchpad.net/ubuntu/+source/cups/+bug/465916 (Both of these have suggested patches). –  Kurt Pfeifle Aug 8 '10 at 9:55

1 Answer 1

For second problem, add avahi daemon to autostart and run it:

PH34R# echo "avahi_daemon_enable=YES" >> /etc/rc.conf
PH34R# /usr/local/etc/rc.d/avahi-daemon start
Starting avahi-daemon.
PH34R# avahi-browse -a
+   bge0 IPv4 PH34R                      _workstation._tcp    local
....snip....
share|improve this answer
    
The avahi daemon is enabled & is running (verified by pgrep & appearance on Linux) –  Maciej Piechotka Aug 11 '10 at 16:44
    
Is there a firewall on server? –  SaveTheRbtz Aug 12 '10 at 8:19
    
Ups. Sorry - I haven't got message. Yes but it was tested without. –  Maciej Piechotka Aug 18 '10 at 10:47
    
Hmm. avahi-browse -a started working after upgrade to 8.1 –  Maciej Piechotka Aug 20 '10 at 10:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.