Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Prior to upgrade, the network interfaces were configured with brex_ifconfig statements in rc.conf. After upgrade, this fails.

If I log in locally, and do ifconfig from the command line, and then start by hand all the services that failed because they couldn't find a configured network interface, everything works fine.

I've tried destroying the interfaces to re-configure them, but ifconfig destroy fails with an error message.

Any ideas gratefully received.

share|improve this question
    
I suggest that, after logging in locally, you restart networking (something like /etc/rc.d/netif restart) and look for errors, then paste those here. Sorry I can't be more specific, as I don't have FreeBSD installed at the moment. –  fission Aug 8 '10 at 11:26
    
What does brex_ifconfig mean ? –  eugene y Aug 9 '10 at 6:33
    
The interfaces are bre0 and bre1, so statements beginning bre0_ifconfig and bre1_config are used in rc.conf. Thanks for the hint, @fission. I found that /etc/network.subr was incomplete. –  bocarp Aug 9 '10 at 15:33
2  
@bocarp: Ah. It should be ifconfig_bre0 anyway.. –  eugene y Aug 10 '10 at 6:42
    
Oh, duh. Yes, I was doing it from memory. You get the idea, anyway. And it all works lovely, now. –  bocarp Aug 10 '10 at 14:24
show 1 more comment

1 Answer 1

Make sure that /etc/network.subr is complete

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.