Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a website running on a Windows 2008 Server EC2 instance. The website is working fine, but I'm unable to remote-desktop into it.

I have an Elastic IP associated with the instance:

# telnet 999.99.999.999 80
Trying 999.99.999.999...
Connected to ec2-999-99-999-999.compute-1.amazonaws.com (999.99.999.999).
Escape character is '^]'.
helo
HTTP/1.1 400 Bad Request
Server: Apache-Coyote/1.1
Transfer-Encoding: chunked
Date: Mon, 09 Aug 2010 08:39:34 GMT
Connection: close

0

Connection closed by foreign host.

# telnet 999.99.999.999 3389
Trying 999.99.999.999...
telnet: connect to address 999.99.999.999: Connection timed out
telnet: Unable to connect to remote host: Connection timed out

# telnet ec2-994-996-996-992.compute-1.amazonaws.com 80
Trying 994.996.996.992...
telnet: connect to address 994.996.996.992: Connection timed out
telnet: Unable to connect to remote host: Connection timed out

Remote Desktop protocol (3389) IS allowed for the instance's security group:

RDP tcp 3389    3389    0.0.0.0/0   --
share|improve this question
    
It might be worth mentioning that running RDP to 0.0.0.0/0 (e.g. everyone and anyone) may not be the best idea. –  crb Aug 9 '10 at 10:01

1 Answer 1

up vote 0 down vote accepted

I had been working away, trying to resolve this problem for the last hour and a half before I posted on SF and finally I figured out the issue!

The default password in cleartext had a 'c' in it, which when viewed in notepad, looked like an UPPERCASE 'C' to me... and I had been trying that all this while!

Moreover Remote Desktop in Windows doesn't seem to allow copy-pasting username/passwords anymore, so that definitely made matters much worse for me!

share|improve this answer
    
If you don't like how it wont let you copy passwords, I think you can change the remote desktop server settings so they are less restrictive. There are basically 3 settings for remote desktop: not enabled, traditional, and most secure. Its obvious if you open the settings control panel. –  djangofan Dec 8 '11 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.