Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an app running on top of sharepoint.

Can I change, through configuration, the default web page for a Sharepoint site to a sub-site page? I tried changing it in IIS but it simply doesn't work: The current default page isn't mapped there, anyway.

I would like to change it from "http://server/default.aspx" to, say, "http://server/test/default.aspx".

Edit: I am using SharePoint 2007

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Editing the web.config file with these lines (under system.web):

<urlMappings enabled="true"> 
     <add url="~/" mappedUrl="/test/default.aspx"/> 
</urlMappings>

did the trick.

share|improve this answer

A specific sharepoint version would help for more specific commentary, but this would be configured in the SP Siite Admin interface, not directly in IIS.

share|improve this answer
    
Thanks, question edited. –  Rodrigo Gama Aug 10 '10 at 16:14
    
Are you able to log into the SP "Central Aministration" interface? It should be available from the current default page. From there, to go Application Management, and create a site collection - point that to your custom app's default page. –  Kara Marfia Aug 10 '10 at 16:47
    
Unfortunatelly, my clients' Sys Admins won't let me create another site collection. Also, I couldn't edit the default page at "Central Administration" on my test env (couldn't find the option to change the default or to forward / to /test/). Also tried adding <urlMappings> to my web.config, no succes though. Any other hint? –  Rodrigo Gama Aug 10 '10 at 19:07
    
Wow, my bad... I got an error on urlMappings. This worked for me as a charm: <urlMappings enabled="true"> <add url="~/" mappedUrl="/test/default.aspx"/> </urlMappings> –  Rodrigo Gama Aug 10 '10 at 19:29
    
Editing the page directly may not work long-term, as I believe SP will re-create some of its code as changes are made to the main interface. However, I'm glad you found a fix. ;) –  Kara Marfia Aug 10 '10 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.