Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok I'm a newb to AIX and Named, so hopfully I'm just missing something easy. :)

The goal is to just have smooth DNS lookups in this goofy Windows workgroup/AIX DNS setup (it will change eventually, but for now I'm limited in the infrastructure changes I can make), and forward any unknowns out to OpenDNS.

As I have it set now, it's 'mostly' working. But if I use NSLookup from a Windows machine it fails to resolve host names unless I speicify the FDQN.

NSLookup on Windows machine:

> ts02
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Non-authoritative answer:
Name:    ts02
Address:  67.215.65.132

(67.215.65.132 is OpenDNS.)

If I NSLookup with the FQDN (Windows machine):

> ts02.intranet.domainname.com
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Name:    ts02.intranet.domainname.com
Address:  10.0.13.5

If I NSLookup from th AIX machine itself:

# nslookup ts02
Server:  ccserver
Address:  0.0.0.0

Name:    ts02.intranet.domainname.com
Address:  10.0.13.5

It resolves as expected.

But if I Dig from the AIX server:

; <<>> DiG 9.4.2-P2 <<>> ts02
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 495
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 13, ADDITIONAL: 0

;; QUESTION SECTION:
;ts02.                          IN      A

;; ANSWER SECTION:
ts02.                   0       IN      A       67.215.65.132

;; AUTHORITY SECTION:
.                       514925  IN      NS      d.root-servers.net.
.                       514925  IN      NS      c.root-servers.net.
.                       514925  IN      NS      g.root-servers.net.
.                       514925  IN      NS      h.root-servers.net.
.                       514925  IN      NS      k.root-servers.net.
.                       514925  IN      NS      m.root-servers.net.
.                       514925  IN      NS      b.root-servers.net.
.                       514925  IN      NS      e.root-servers.net.
.                       514925  IN      NS      l.root-servers.net.
.                       514925  IN      NS      i.root-servers.net.
.                       514925  IN      NS      a.root-servers.net.
.                       514925  IN      NS      f.root-servers.net.
.                       514925  IN      NS      j.root-servers.net.

;; Query time: 99 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)

Dig from the AIX, with the FQDN:

; <<>> DiG 9.4.2-P2 <<>> ts02.intranet.domainname.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 269
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;ts02.intranet.domainname.com. IN A

;; ANSWER SECTION:
ts02.intranet.domainname.com. 900 IN A 10.0.13.5

;; AUTHORITY SECTION:
intranet.domainname.com. 900 IN NS  ns1.intranet.domainname.com.

;; ADDITIONAL SECTION:
ns1.intranet.domainname.com. 900 IN A 10.0.13.2

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)

My /etc/resolv.conf:

# cat resolv.conf
domain intranet.domainname.com
Nameserver 127.0.0.1

I'm beating my head against the wall, so any ideas are appreciated. I can also supply more info if required...

Thanks in advance!


UPDATE:

Ok as suggested, I added the "search" back into the resolv.conf:

# cat resolv.conf
domain intranet.domainname.com
search intranet.domainname.com
Nameserver 127.0.0.1

Which doesn't appear to make any difference. I had had the search in there previously, but removed it after reading online (IBM's site) that it wasn't needed if there was only one domain. I'll leave it in there.

I can also ping to and from the AIX server, as well as between Windows hosts, either with or without the FQDN, and it resolves as expected.

But NSLookup from the Windows host(s) still fails unless I use the FQDN, including trying to look up the DNS server by the usual (and existing) "ns1" alias:

C:\>nslookup ccserver
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Non-authoritative answer:
Name:    ccserver
Address:  67.215.65.132


C:\>nslookup ns1
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Non-authoritative answer:
Name:    ns1
Address:  67.215.65.132


C:\>nslookup ccserver.intranet.domainname.com
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Name:    ccserver.intranet.domainname.com
Address:  10.0.13.2


C:\>nslookup ns1.intranet.domainname.com
Server:  ccserver.intranet.domainname.com
Address:  10.0.13.2

Name:    ns1.intranet.domainname.com
Address:  10.0.13.2

I've got no new ideas so if anyone else does, please help a brother out. :)

share|improve this question
add comment

1 Answer 1

Don't you just need to update your resolv.conf file?

# cat /etc/resolv.conf
domain intranet.domainname.com
search intranet.domainname.com
Nameserver 127.0.0.1
share|improve this answer
1  
That is what I was about to post. –  Zoredache Aug 9 '10 at 20:42
    
The thing is, it WAS set like that until just before I posted this. I had added the "search" a few days ago in an attempt to help straighten things out. I made the change back after reading that the "search" is in addition to the primary "domain" entry, and only needed if you want to search domains beyond the primary. :( I'll go add it back and double-check... –  techie007 Aug 10 '10 at 1:29
    
Yeah, adding the search back didn't help any. :( I'm going to update the question with a bit more info.. –  techie007 Aug 10 '10 at 1:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.