Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to capture all of the traffic to and from an Apache2 web server for troubleshooting purposes, so I did the following to try to set mod_dumpio up properly:

  1. Used a2enmod to enable mod_dumpio
  2. Changed LogLevel to "debug" in apache2.config
  3. Added "DumpIOInput On", "DumpIOOutput On" and "DumpIOLogLevel debug" to apache2.config
  4. Issued "/etc/init.d/apache2 restart" to restart Apache
  5. Issued "apache2ctl -t -D DUMP_MODULES" to make sure mod_dumpio was loaded

I'm watching /var/log/apache2/error.log, but not seeing much there, and certainly not a dump of all input and output.

Can anyone help?

share|improve this question

2 Answers 2 it!

The problem was apparently that just one of my VirtualHosts (as defined in /etc/apache2/sites-enabled) had a LogLevel declared that was something other than debug, thus interfering with the overall behavior of mod_dumpio for reasons that escape me :)

I hope someone else finds this helpful.

share|improve this answer
Note that if the LogLevel directive is set anywhere in the base httpd.conf or apache2.conf, it will prevent the module from logging (despite what the Apache docs seem to indicate). –  Bruce Alderson Aug 2 '11 at 18:50

I've been struggling with this for a day, too. It seems they moved mod_dumpio output to the log level 'trace7' and disabled parameter DumpIOLogLevel.

I needed

LogLevel trace8


LogLevel info dumpio:trace8

for it to work.

Do remember that you usually have LogLevel at two levels, server level and virtual host level, check both.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.