Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a laptop with Windows 7 ultimate enterprise edition installed. This is a company laptop so i have domain account as I am a domain user but also a local administrator on my laptop. My problem is that now i am out of the company premises for some days and when i login via my account it takes a hell lot of time to login because it tries to authenticate me on the domain (probably). Can i someway disable this "searching for the domain network" so that i login faster, like a local login account on the laptop does?

share|improve this question

5 Answers 5

Your IT department probably doesn't want you logging-on with a local account. As a second-best strategy, I'd recommend you try disabling your wireless NIC and not connecting any wired network cables until after you've logged-on. The total absence of network connectivity should cause the logon process to proceed speedily with cached credentials.

share|improve this answer
    
Well actually they have given me this laptop for use in case i am traveling. I have already tried disabling the wireless and then logging but it does not work out. –  Darsin Aug 10 '10 at 4:43

Login to windows when your not connected to any network. That way windows wont be trying to search for an AD server.

Once your logged in, plug-in your cable/turn on your wifi.

share|improve this answer
    
I have tried to do the same, i disabled my wireless connection and logged in but there was no difference. The only solution out was to create another local account with local administrator privileges. Which has its own issues that it is not same as the built in Administrator account as i keep on running into other access related issues. –  Darsin Aug 10 '10 at 4:43

We had this problem as well not so long ago. Our fix was to change the DNS settings to match the domain controller (i.e. our AD server). If this works for you, you could have your AD server as your primary DNS and some other public DNS such as OpenDNS as the secondary so that you can still access the internet.

share|improve this answer
2  
It is a requirement that domain members use the AD DNS if they are to function correctly. You shouldn't be using a secondary DNS server that isn't part of AD either, or it will give you all sorts of weird problems when connected to the corporate network. Most corporate networks (and home/public networks) will use DHCP, so you shouldn't need to touch DNS at all, as it will just do the right thing when you move between networks. –  Bryan Aug 10 '10 at 6:56
    
Oh yes, didn't think about that - so if a primary DNS can't be found (if one is explicitly defined in the adapter properties), it will fall back to the router and do what ever is defined there; correct? –  emtunc Aug 10 '10 at 7:06

This doesn't sound normal, but I've seen the same behaviour before (albeit on Windows XP).

In our case, it was a logon script that attempting to pipe the output of some commands to a network share. As the logon script was cached, but the network share wasn't available the logon process took far longer than it should have done when not connected to the corporate network.

Try enabling verbose user environment logging and then logging on with the network disconnected, once it does let you in, review the userenv.log file and see what is causing the delay.

share|improve this answer

Are there any mapped drives or saved locations that point to a network drive? That has caused issues w/ some of my users. Check to see if you have any log on scripts running that would be doing the mapping.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.