Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sometimes people delete files they shouldn't, a long-running process still has the file open, and recovering the data by catting /proc/<pid>/fd/N just isn't awesome enough. Awesome enough would be if you could "undo" the delete by running some magic option to ln that would let you re-link to the inode number (recovered through lsof).

I can't find any Linux tools to do this, least with cursory Googling.

What do you got, serverfault?

EDIT1: The reason catting the file from /proc/<pid>/fd/N isn't awesome enough is because the process which still has the file open is still writing to it. A delete removes the reference to the inode from the filesystem namespace. What I want is a way of re-creating the reference.

EDIT2: 'debugfs ln' works but the risk is too high since it frobs raw filesystem data. The recovered file is also crazy inconsistent. The link count is zero and I can't add links to it. I'm worse off this way since I can just use /proc/<pid>/fd/N to access the data without corrupting my fs.

share|improve this question

7 Answers 7

It sounds like you already understand a lot, so I won't go into excess detail. There's several methods to find the inode and you can usually cat and redirect STDOUT. You can use debugfs. Run this command within:

ln <$INODE> FILENAME

Make sure you have backups of the filesystem. You'll probably need to run a fsck afterwards. I tested this successfully with an inode still being written to and it does work to create a new hard link to a dereferenced inode.

If the file is unlinked with an unopen file in ext3, the data is lost. I'm not sure how consistently true this is but most of my data recovery experience is with ext2. From the ext3 FAQ:

Q: How can I recover (undelete) deleted files from my ext3 partition? Actually, you can't! This is what one of the developers, Andreas Dilger, said about it:

In order to ensure that ext3 can safely resume an unlink after a crash, it actually zeros out the block pointers in the inode, whereas ext2 just marks these blocks as unused in the block bitmaps and marks the inode as "deleted" and leaves the block pointers alone.

Your only hope is to "grep" for parts of your files that have been deleted and hope for the best.

There's also relevant information in this question:

http://serverfault.com/questions/145506/i-overwrote-a-large-file-with-a-blank-one-on-a-linux-server-can-i-recover-the-ex/145510

share|improve this answer
    
Comment hopefully deleted as it was not revelent. –  mdpc Aug 10 '10 at 16:39
    
In the case of a deleted but still open file I don't think it would zero out the pointers in the inode. Also, instead of using "ln" in debugfs I'd use "undel" so that the inode reference counts will correctly get updated. –  Mark Wagner Aug 10 '10 at 19:13
    
I didn't mean to allude as such, embobo. It doesn't, I tested the performance. I've clarified my language. –  Warner Aug 10 '10 at 19:21
    
Clever, but corrupts my filesystem. :) –  mbac32768 Aug 11 '10 at 17:32
    
It's the only solution for the scenario as you describe it. Manipulating a filesystem on a low level that is mounted rw and actively being written to is likely to cause corruption in almost all scenarios. –  Warner Aug 11 '10 at 17:44

Awesome enough would be if you could "undo" the delete by running some magic option to ln that would let you re-link to the inode number (recovered through lsof).

This awesomeness was introduced to ln in v8.0 (GNU/coreutils) with the -L|--logical option which causes ln to dereference a /proc/<pid>/fd/<handle> first. So a simple

ln -L /proc/<pid>/fd/<handle> /path/to/deleted/file

is enough to relink a deleted file.

share|improve this answer
3  
This doesn't work; if the file is deleted it will fail. –  Random832 Jun 20 '11 at 22:47
1  
No, it won't. I regularly use this to restore deleted but still opened files. But you need to make sure, that the new /path/to/deleted/file is on the same filesystem as the file was just before it was deleted, else this will - indeed - fail. (You can get the old path with ls -l /proc/<pid>/fd/<handle>) –  tnimeu Jul 28 '11 at 20:39
1  
This sort of functionality (See this question and answer) was specifically rejected as a security risk [to a hypothetical security scheme revolving around a privileged process giving your process a read-only file handle to a file you own but do not otherwise have access to]; I tried it (though with a small C program to directly use the relevant system call) and it did not work. –  Random832 Aug 24 '11 at 19:28
    
I, of course, did test this before posting my solution and at that time it actually worked for me. What I wasn't aware of is that it only worked on tmpfs filesystems but not on e.g. ext3. Furthermore this feature got completely disabled in 2.6.39, see the commit. So therefore this solution won't work with kernel 2.6.39 or newer anymore and in earlier versions it depends on the filesystem. –  tnimeu Jan 26 '12 at 14:04
    
@tnimeu ln -L does not work for me. I have a deleted file and I tried to relink it to the original path. ln gives me a ln: failed to create hard link /my/path/file.pdf => /proc/19674/fd/16: No such file or directory. But I can e.g. successfully cat /proc/19674/fd/16 –  Eugene Beresovksy Aug 21 '13 at 6:46

the debugfs way as you saw doesn't really work and at best your file will be deleted automatically (due to the journal) after reboot and at worst you can trash your filesystem resulting to "reboot cycle of death". The Right Solution (TM) is to perform the undelete in the VFS level (which also has the added benefit of working with practically all current Linux filesystems). The system call way (flink) has been shot down every time it appeared in LKML so the best way is through a module + ioctl.

A project that implements this approach and has reasonably small and clean code is fdlink (https://github.com/pkt/fdlink.git for a version tested with ubuntu maverick's kernel). With it, after you insert the module (sudo insmod flink_dev.ko) you can just do "./flinkapp /proc//fd/X /my/link/path" and it will do exactly what you want.

You can also use a forward-ported version of vfs-undelete.sourceforge.net that also works (and can also automatically relink to the original name), but fdlink's code is simpler and it works just as well, so it is my preference.

share|improve this answer

I don't know how to do exactly what you want, but what I would do is:

  • Open the file RO from another process
  • Wait for the original process to exit
  • Copy the data from your open FD to a file

Not ideal, obviously, but possible. The other option is to play around with debugfs (using the link command), but that's kind of scary on a production machine!

share|improve this answer
    
The debugfs link command doesn't support this use case at all. –  mbac32768 Aug 10 '10 at 16:53
    
tldp.org/HOWTO/Ext2fs-Undeletion-11.html suggests that it does. I haven't tried it, but that seems reasonable. –  Bill Weiss Aug 10 '10 at 18:18
    
link didn't work in my testing but ln did. –  Warner Aug 10 '10 at 19:16

Interesting question. An interviewer asked the same question to me in a job interview. What I told him was that there was not a easy way to do this and in general was not worth the time and effort involved. I did ask him what he thought the solution to this issue was ....

  1. Use lsof to find the inode number on the disk for the process as it will still appear even if the file has been deleted...the key is that it is still open.
  2. Extract the information from the filesystem based on this via a filesystem debugger.
share|improve this answer
    
I can extract the data just fine from /proc/<pid>/fd/N but that's not what I'm trying to do. –  mbac32768 Aug 10 '10 at 16:51

Use Sleuthkit icat.

sudo icat /dev/rdisk1s2 5484287 > accidentally_deleted_open_file
share|improve this answer
    
This works by bypassing the operating system's filesystem functionality and parsing the disk bytes directly. –  Flimm Jul 3 at 12:24

Ran into the same problem today. The best I could come up with is to run

% tail -n +0 -f /proc/<pid>/fd/<fd> /path/to/deleted_file

in a tmux/screen session until the process ends.

share|improve this answer
2  
Linking to the original files, as in the accepted answer, should work. –  Chris S Dec 6 '12 at 16:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.