Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've created a user account to run some tasks, If I run the task with my account but using "Run As" taskmanager user, the task runs ok (no permission problems, and get what I'm expecting). But if I run the same task using taskmanager It fails 0x1 and I get the next error on Security EventLog (in spanish sorry):

Tipo de suceso: Errores 
Origen del suceso:  Security 
Categoría del suceso:   Uso de privilegios  
Id. suceso: 578
Fecha:      10/08/2010 
Hora:       11:55:05 
Usuario:        TEST\tareasprogramadas 
Equipo: TEST_NT6 
Descripción: Operación de objetos con privilegios:      
Servidor de objetos:    Eventlog    
Identificador de objeto:    0   
Id. de proceso:     400     
Nombre de usuario principal:    TEST_NT6$   
Dominio principal:  TEST    
Id. de inicio de sesión principal:  (0x0,0x3E7)     
Nombre de usuario cliente:  tareasprogramadas   
Dominio de cliente: TEST    
Id. de inicio de sesión de cliente: (0x2,0xD5DAEC40)    
Privilegios:        SeSecurityPrivilege

Para obtener más información, vea el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp.

The Task simply gets Security Audit from EventLog (PsLogList.exe). Any Idea?

Thanks, BR

share|improve this question
    
SORRY, close this. The problem is security over Security EventLog. –  elgransan Aug 10 '10 at 15:32
add comment

1 Answer 1

By using the "Run As" command you're really not running it as your user, you're "running" it "as" the account that you enter when doing the Run As. They're two completely different security contexts. If the task fails under your account then you don't have the proper permissions to run the task in question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.