Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
  • I just mounted a newly purchased XServe.
  • I have turned on the XServe.
  • I have installed Apple Server Admin Tools on a second computer.
  • I can see the newly purchased XServe under "Ready for Setup" in Server Admin.
  • I can select the server and press the "Set Up..." button.
  • ... and nothing happens.

I confirmed this on two computers. Some notes:

  • The XServe under Server Admin has a version number of 10.6.1. I am attempting to use Server Admin 10.6.4. I could not find a copy of Server Admin 10.6.1, though a 10.6 version exists.
  • The XServe is connected to the network via network port 1.

My question:

Has anyone experienced this issue, and knows how to resolve it WITHOUT directly attaching a monitor/keyboard?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I've seen this before -- Server Admin is supposed to run Server Assistant to do the remote setup, but for some reason can't seem to find it (I think it's not getting registered with Launch Services, or some such). The solution is simple: navigate to /System/Library/CoreServices/, and run Server Assistant yourself. You can either proceed to the setup there, or quit it and (now that Launch Services knows about it) re-trigger it from Server Admin.

share|improve this answer
    
I'll try this out this weekend, thanks for the tip! –  Jake McGraw Aug 13 '10 at 22:02
add comment

Never had those problems. One thing you could try is to boot from CD, which needs physical presence and, shortly, a connected keyboard. Just enter the MacOS install CD, restart the system while pressing the C key on the keyboard. Hold it pressed for about a minute or two and then disconnect it again and see if appears again in Server admin and is installable this time.

If I remember correctly you can even avoid to have to connect a keyboard if you press the power button in a certain way. This is documented in the Xserve installation manual.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.