Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a single-server deployment of Sharepoint Foundation 2010 (via Microsoft Search Server 2010 Express).

When it comes to searching content in a basic Sharepoint site the stand-alone search page at http://domain/site/search/default.aspx the required results turn up. However when I use "Search this site..." below the ribbon I receive:

We did not find any results for keyword.

Is there any way to hook this into the main search results?

Update: Unfortunately the below solution has the side effect of causing it to be unable to sync STSSync lists (e.g. Discussions) in Outlook with the error:

Task 'SharePoint' reported error (0x80070005) : 'You do not have permission to view this SharePoint List (XXX - XXX). Contact the SharePoint site administrator. HTTP 302.' Therefore I must choose one or the other.

Therefore, I can currently have one or the other, but not both.

share|improve this question
    
What is the url of "Search this site..." results. I ask because I suspect that in the first case you use single-label domain name and in the second it might be not and would require to tell that it is local –  Gennady Vanin Novosibirsk Aug 11 '10 at 6:57
    
The "Search this site..." is on the home page of the site at domain/site/default.aspx, and it redirects to domain/site/_layouts/… - one key point you've unearthed is that if I remote the &u=internetdomain the results do show up. –  Aaron - Solution Evangelist Aug 11 '10 at 7:26
    
Hi, Solution Evangelist, I was banned from site and lost my discussions.I could not understand: 1)HTTP302 - strange error; have you typed it correctly? 2)Mike Hacker's Blog tells "that the issue is related to security changes made in Windows Server 2008 R2 and Windows 7". But what issue? Can it be connected to serverfault.com/questions/170476/… ? –  Gennady Vanin Novosibirsk Aug 26 '10 at 20:16
    
    
show 1 more comment

1 Answer 1

up vote 2 down vote accepted

Problem solved! Due to an issue with the crawler indexing sites with Basic Authentication and Anonymous authentication on Server 2008 R2 (see Mike Hacker's Blog). I've developed a workaround by extending the Extend the Web Application and create a second one at http://netbios:81 with NTLM authentication enabled.

It turns out this was interfering with the search because this wasn't the default on the Alternate Access Mappings so the search scopes weren't working.

Under Central Administration > Edit Public Zone URLs I set the URLs as follows and it works:

Default: http://netbios:81
Intranet: http://netbios
Internet: https://domain
Extranet: http://domain

share|improve this answer
    
Thanks for answering! Keep going –  Gennady Vanin Novosibirsk Aug 11 '10 at 12:08
    
Thanks vgv8! I'll be sure to follow SF more closely and become more involved as this is one area where I work a great deal! –  Aaron - Solution Evangelist Aug 11 '10 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.