Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed apache server 2.2 from this site and am trying to start apache but it shows me the following errors:

could not bind  to address  0.0.0:80  could not  reliably determine   server's fully  qualifed domain  name  using  192.168.1.100 for server name

Please help. Would it be more helpfull how copy full screenshot from command line?

share|improve this question
    
You've probably have a typo in the config. It should be 0.0.0.0:80, not 0.0.0:80. –  szbalint Aug 11 '10 at 14:09
add comment

migrated from stackoverflow.com Aug 11 '10 at 14:56

This question came from our site for professional and enthusiast programmers.

3 Answers

From your duplicate question on StackOverflow, it looks like you're already running IIS on that port, so Apache HTTPD can't start instead of it (unless you've configured your Apache HTTPD server to show the IIS welcome image, but that's very unlikely to be the default configuration).

Shut down IIS first.

share|improve this answer
add comment

This isn't much of an answer but are you running Skype on your Windows machine? Because skype uses port 80 which in turn will not allow you to run a webserver, however you can change the settings in skype to use a different port then try running Apache again.

share|improve this answer
add comment

you computer doesn't have a ptr record associated with the IP address. Add your computer name/ip to your hosts file (on windows I think it is in c:\windows\system32\drivers\etc\hosts.txt), or set a servername configuration directive in apache config. But this should probably be over on serverfault.com as opposed to here. but the cannot bind could either be typo, or could be that port 80 already in use, IIS installed/running)

share|improve this answer
    
how please help –  dato datuashvili Aug 11 '10 at 14:35
    
well edit the server config file (wherever you installed it). But per your other question, if you see it works, then you have apache installed and running. –  Doon Aug 11 '10 at 14:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.