Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I’d created a PST at the location c:\pstfiles\user.pst to test importing PSTs into Exchange 2010 via PowerShell.

I’d already installed 64bit outlook on the server, and added import export roles to the account I was using.

I was then using the command ‘Import-Mailbox –Identity [Username] –PSTFolderPath c:\pstfiles\user.pst’ to import this pst file into [username]’s mailbox.

And hit the following error:

Error was found for XXX because: Error occurred in the step: Approving object. An unknown error has occurred., error code: -2147221219 + CategoryInfo : InvalidOperation: (0:Int32) [Import-Mailbox], RecipientTaskException + FullyQualifiedErrorId : CFFD629B,Microsoft.Exchange.Management.RecipientTasks.ImportMailbox

I'm struggling to find information on what this means, please help!

share|improve this question

3 Answers 3

You need to give the Exchange Trusted Subsystem read/write access to the folder that contains the PST. Try again after adding this to your ACL on the pstfiles folder.

share|improve this answer

Try changing -identity [username] to -identity [display name / email address / exchange alias]
Edit Just noticed there is a ' at the end of your command is this a typo or was it intentional?

share|improve this answer
    
So I had to postpone the project but I am now back on it with the help of the following website: sysadmin-talk.org/2010/08/… Even with this information it's still a bit of a pig. It would be great to hear if anyone else is having problems/ has succeeded. –  user50729 Sep 7 '10 at 16:55

You could try running fixmapi at the command prompt. That's fixed this error in the past.

Also, Exchange 2010 SP1 is still in Beta. It is possible this is a bug as SP1 isn't ready for production yet. EDIT

Since that didn't work, try this:

get-mailbox | Add-mailboxpermission -User Administrator -AccessRights FullAccess

Looks like it might be a permissions issue
http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/886a6c39-b975-408a-827c-fb3c07ea579b

Also try running powershell as administrator

share|improve this answer
    
Thanks for your answer Jason, I have tried this today but I still get the same message. I have read some articles on importing PSTs into 2010, hence getting as far as I have got, but I’m lost now. Has anyone here succeeded? –  user50729 Aug 12 '10 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.