Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just finished installing ArcGIS Server 10 and completed the post-installation. The ArcGIS Server Object Manager service is installed, but when I try to start it, I get the following error:

"Windows could not start the ArcGIS Server Object Manager service on the Local Computer.

Error 1067: The process terminated unexpectedly."

The agsadmin and agsusers groups exist, and my local account is a member of the agsadmin group.

Any ideas on what I've done wrong?

Thanks,

Jon.

share|improve this question

3 Answers 3

Try resetting passwords for SOM, SOC and ArcGISWebServices accounts

share|improve this answer

You also should look in the Application and System logs (Control Panel -> Administrative Tools -> Event Viewer) for clues as to why the service failed to start. Does it have some kind of dependency that is not being met?

Also, services often fail to start because they do not have valid credentials:

  1. Start -> Run -> services.msc
  2. Right-click on the "ArcGIS Server Object Manager" service and choose Properties
  3. Select the "Log On" tab
  4. Enter a valid username/password (if you are not sure whether the service account you are currently using has sufficient permissions, you can use a local admin account temporarily for testing purposes)
share|improve this answer
    
Dependencies are all running. Event logs are showing generic error codes & messages. The service is using valid credentials. –  SpatialBridge Aug 13 '10 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.