Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2003 R2 server "appserver" with various shares, I can access this server and shares from any machine on the network accept from itself.

I can list the shares by going to "\appserver\" but when i try to access any of the shares I getthe error message "No network provider accepted the given network path".

This is very strange since I have three very similar servers running the same os, in the same domain, with the same permissions on it's shares and they can access their own shares without problems.

I have done a lot of googling and found reference to LSA loopback connections. I have applied these fixes but still get the same error message.

Any help or ideas would be much appreciated as this has me stumped.

Update

It appears that I can only connect to this machine remotely (shares, remote registry) etc if I use the FQDN. I can however ping the machine with it's short name and get a response the domain name is appended (as expected) to the dns request.

share|improve this question
    
Does the server know that it's named "appserver" or is that just a DNS name? In other words, does it have a different computer name in sysdm.cpl? –  Skyhawk Aug 13 '10 at 6:32
    
Thanks for the response. Yes it is named appserver in sysdm.cpl aswell as in DNS. –  AdamW Aug 13 '10 at 8:42
add comment

2 Answers

I have done a lot of googling and found reference to LSA loopback connections. I have applied these fixes but still get the same error message

This is apparently by http://support.microsoft.com/kb/896861(You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or a later version) which has two metods. Well, the name of the article is a little bit misleading since it is also applies to ГТС shares...

If you used "Methods 2: Disable the loopback check (less-recommended method)", tricking registry, then you should also reboot machine.

PS. Method2 is proper only in development. Use Method1 on production server.

share|improve this answer
add comment

The solution: Run services.msc via start, right click and select properties for apache2.2 and the Logon tab. Select use This Account and enter the login name for Windows (.\Username) and the password used (supposing it's the same account who has access to the UNC map) This gives Apache access to the UNC path and can therefore be used eg Mapped driveletters are still not allowed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.