Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My DNSmasq configuration is as follows:

dhcp-range=private,192.168.128.100,192.168.128.200
dhcp-range=public,192.168.129.100,192.168.129.200
dhcp-option=private,option:router,192.168.128.1
dhcp-option=private,option:dns-server,192.168.128.1
dhcp-option=public,option:router,192.168.129.1
dhcp-option=public,option:dns-server,192.168.129.1

dhcp-boot=net:private,pxegrub.img,suo,192.168.128.8

dhcp-host=00:16:b6:d9:bd:58,net:private,192.168.128.1,poks
dhcp-host=00:13:d4:64:11:c3,net:private,192.168.128.7,keshi
dhcp-host=00:0e:a6:f9:0a:f4,net:private,192.168.128.8,suo
dhcp-host=00:22:15:14:df:07,net:private,192.168.128.9,ranbo
dhcp-host=52:54:00:c5:c4:ac,net:private,192.168.128.10,mythbox

domain=i.naked.iki.fi
server=/i.naked.iki.fi/
no-hosts

However, when attempting to resolve the addresses from the DNS server, the dhcp-host addresses are not answered:

root@poks:~# host keshi.i.naked.iki.fi 192.168.128.1
Using domain server:
Name: 192.168.128.1
Address: 192.168.128.1#53
Aliases: 

Host keshi.i.naked.iki.fi not found: 3(NXDOMAIN)
root@poks:~# host keshi. 192.168.128.1
Using domain server:
Name: 192.168.128.1
Address: 192.168.128.1#53
Aliases: 

Host keshi. not found: 3(NXDOMAIN)
root@poks:~# host 192.168.128.7 192.168.128.1
Using domain server:
Name: 192.168.128.1
Address: 192.168.128.1#53
Aliases: 

Host 7.128.168.192.in-addr.arpa. not found: 3(NXDOMAIN)

What am I configuring wrong? How can I get DNS to answer for those hosts without adding separate "address" lines for them. I'd also like the reverse records served properly.

Thank you in advance.

share|improve this question
    
heh, the heading got somehow mightily garbled :-) –  Nakedible Aug 12 '10 at 20:14

2 Answers 2

up vote 1 down vote accepted

I'm not sure if it's quite what you want, but I do something similar except that I put just the MAC to name mapping in the dnsmasq.conf and put the name to IP mapping in /etc/hosts.

share|improve this answer
    
Thanks, that is an option for me. However, I'd like the dnsmasq configuration to be completely standalone, if I can manage... –  Nakedible Aug 13 '10 at 20:50
    
Actually, now that I read the dnsmasq documentation again, it seems that dnsmasq answers the DHCP addresses for active leases only - or atleast so it seems. So it might be that your solution is indeed the only one without specifying the addresses by hand. –  Nakedible Aug 13 '10 at 20:59

add infinite as lease time, so the lease is always active

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.