Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just upgraded a simple Ubuntu webserver from 9.10 to 10.04.1 and our nagios claims UNKNOWN for the single snmp check we run against it. It was working previously, so this baffles me.

I installed the plugins on my desktop and get this output when I run it (obfuscated where appropriate:

$: ./check_snmp_storage.pl -H $HOSTNAME$ -C $pword$ -m / -w 90 -c 95
ERROR: Description/Type table : No response from remote host $HOSTNAME$`

So I installed nagios plugins on the webserver and get the same output, unless I use localhost for $HOSTNAME$.

The snmpd.conf is pretty trivial, and I wonder if that's the problem?

syslocation  "ESX Server"
syscontact  admin@example.com
rocommunity  pword
disk  /
load  30 30 30
share|improve this question
    
Have you tried snmpwalk from your nagois box? –  Andrew Aug 13 '10 at 3:01

1 Answer 1

up vote 3 down vote accepted

Check the file /etc/default/snmpd. By default on debian/ubuntu this file has an option which restricts snmp to the local host. Here is a diff from the stock config. I have seen this get reverted back to the stock config during an upgrade.

--- a/default/snmpd
+++ b/default/snmpd
 # snmpd options (use syslog, close stdin/out/err).
-SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'
+SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid'

If the above isn't the issue, double check the firewall on the host if it has one.

share|improve this answer
    
That may well be it. I don't recall changing it, so it wouldn't have triggered a diff on upgrade. I'll check when I get in tomorrow. –  jldugger Aug 13 '10 at 0:51
    
That was it. Reviewing the changelog shows Debian patched in that in 2006. If I get time I might check etc-keeper and verify that it wasn't there before. –  jldugger Aug 13 '10 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.