Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have students taking a governmental exam using Word 2008 on Mac OS X 10.5. Some administrators feel that they should not be able to use spellchecking or the thesaurus (and, presamably, grammar checking, as well).

There are instructions to turn off the spelling and grammar checking, but it would seem to me that a user could quickly turn them back on again. Is there a way to set this (preferably using Workgroup Manager, or alternatively as a bash command) that would prevent students from easily turning it back on? (And, I suppose, we'll need to re-enable it the next day).

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Most Reward for the Least Effort

Will was on the right track. I've found that the best bang for your buck is to move (or delete) the /Applications/Microsoft Office 2008/Office/Shared Applications/Proofing Tools folder. After you do that, Word's "Tools" menu will no longer contain "Spelling and Grammar" and "Thesaurus", and the "Spelling and Grammar" item in the Preference Pane becomes greyed out.

Users are still able to access the Dictionary, and I was able to tell it to access the Thesaurus through Word once, but could not repeat it in further testing.

[It may be worth pointing out that I couldn't see how to do this from Workgroup Manager, and used Casper to execute my commands at login and logout.]

Being Doubly Safe

Managing Word Preferences through Workgroup Manager

Working from these instructions, I ran Word once, then copied the ~/Library/Preferences folder. I then ran Word again, and set a number of preferences the way I wanted them (such as turning off grammar checking, turning on autorocovery, and turning off checking for automatic updates).

I then diffed the directories (and, after running plutil -convert xml1 com.microsoft.* in both directories to change the plists from binary to xml format, diffing them again) to see where the changes were listed in the plist files. Then in Workgroup Manager, I selected the group I wanted to manage, clicked on "Preferences" on the toolbar, and then the "Details" tab on the right. There I was able to hit the plus button and, one at a time, import the plists that had been modified and delete all the keys that I didn't care about (only retaining the ones that differed and looked useful).

With those settings applied (whether managed "Often" or "Always") users can change them, but the defaults are set.

Blocking the Online Dictionary

I ran iftop and saw that the unit was connecting to businesscentralserver2007.com using HTTP. I had been asked to disable internet access anyway, and using the parental control feature in Workgroup Manager, I disabled access to all sites. [Except apple.com, as you can't disable that.]

Application Whitelisting

Lastly, I whitelisted Office to make it run (and implicitly blacklisted every other application, such as the web browsers). The folders I chose to make accessible were:

  • /Applications/Microsoft Office 2008/
  • /Library/Application Support/Microsoft/
share|improve this answer
    
Diffing .plists to find out what keys changed - always fun. Nice job! –  Chealion Jun 17 '09 at 3:54
    
Thanks. Changes.app is nice for that (although I really loved Beyond Compare when I was working on Windows). Methinks that a dedicated plist-diffing tool would be really nice. –  Clinton Blackmore Jun 17 '09 at 4:01
add comment

hmm.. I'm not sure how it would be done on a Mac but for Windows, it would be changing your Office installation to remove (make not available) the "proofing tools" feature within the "Office Shared Features".

Also, for Windows, the files used for proofing are within the folder:

  • MSGR3EN
  • MSSPELL3

Hope that points you to the right direction.

share|improve this answer
    
Good to know. Thank you. –  Clinton Blackmore Jun 1 '09 at 20:35
add comment

Try this:

  1. Quit Word

  2. Go to System>Preferences | International and change your input local to US English

  3. Launch Word

  4. Go to Word>Preferences | Spelling and Grammar and disable both

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.