Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi First sorry for my English.

I configured a Squid in authentication mode on port 8888 and redirect my network trafic eq www via a route-map to squid server. On the squid server I have used iptables redirect traffic on port 80 to 8888(squid port). When I browse a web in Internet Explorer this error displayed.

The requested URL could not be retrieved

--------------------------------------------------------------------------------

The following error was encountered while trying to retrieve the URL: /

Invalid URL

And this messege present in access.log:

1281752166.811      0 10.32.3.12 NONE/400 1744 GET / - NONE/- text/html

When I set every IP (not squid ip) in the Internet Explorer proxy setting with port 80 ; present authentication window then my requested web.

When squid is configured in transparent mode, it work fine.

share|improve this question

2 Answers 2

From what i gather you are not getting your authentication window when transparent mode but do get it when setting the values manually (Not taking the last line of your question into account).

The reason I am not taking the last line into account is because you cant use authentication with squid when in transparent mode which is why the last line does not make sense.

You have to choose , either get transparent ease of use or manually set the proxies for each pc so that you can get authentication.

share|improve this answer

Maybe you can try automatic proxy configuration. It is still easier than to set up all parameters on each pc, but requires some work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.