Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Since a couple of weeks I can't receive emails with a mailserver, in combination with a VPS server.

When I trace the e-mailadres on http://www.mtgsy.net/dns/utilities.php I get the following result:


Getting MX records for 'domein.nl'

There are 01 MX records (Mail servers) for the domain 'domein.nl'

Testing each mail server in the list using the address info@domein.nl

Testing mail.domein.nl, preference = 10

Checking to see if mail.domein.nl is in any of the popular RBL's - PASSED - Not found in any RBL's

Trying to connect to mail.domein.nl

SUCCESS

220 hosted-by.xynta.nl ESMTP Exim 4.69 Sat, 14 Aug 2010 11:54:18 +0200

EHLO MTGSY.NET

250-hosted-by.xynta.nl Hello frankfurt2.mtgsy.com [85.25.178.12]

250-SIZE 20971520

250-PIPELINING

250-AUTH PLAIN LOGIN

250-STARTTLS

250 HELP

MAIL FROM: postmaster@mtgsy.net

250 OK

RCPT TO: info@domein.nl

250 Accepted

QUIT

221 hosted-by.xynta.nl closing connection


I think this is all OK, but when I check the Inbox with Squirrelmail I can't see the received e-mails.

I can send e-mails without problems.

Does anyone know how to find the solutions for this (big) problem? Tnx

Btw: I'm using DirectAdmin and I have root access to the server

share|improve this question

closed as off-topic by HopelessN00b Apr 3 at 17:02

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Take a look at /var/log/exim4/mainlog + /var/log/exim4/paniclog on the machine itself.

It looks like Exim has accepted the mail, but where it has gone afterward is a mystery.

share|improve this answer
    
In the mainlog everything seems ok (all completed), but in de paniclog I see: "2010-08-14 04:04:36 1Ok66u-0002ph-6k User 0 set for local_delivery transport is on the never_users list" Is this wrong? –  Arjen Aug 14 '10 at 12:55
    
When I look in DirectAdmin at the emailaccounts, the size of the inbox increase when I send e-mails to the server :s –  Arjen Aug 14 '10 at 13:49
    
Clear you paniclog and try resending an email. If the paniclog creates new log lines post those. –  David Rickman Aug 14 '10 at 17:01
1  
Looks like squirrelmail might not be configured to load the mail from the location where it is being delivered - which explains why the size increases but you cannot see it regardless. Check your IMAP server config. As for "never_users list" - that means that user cannot be delivered to .. –  Steve Kemp Aug 16 '10 at 20:22