Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have XAMPP on my Ubuntu Lucid system and everything worked fine. But there seems to be some problem now and mysql wouldn't start.

I had tried to recover a few Drupal databases and hence copied the raw files to /opt/lampp/var/mysql folder like all other database folders. And, I guess that could have caused the problem. I am pasting the last few lines of the error log. Someone please help me out.

100814 15:17:47 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
100814 15:17:47 [Note] Plugin 'FEDERATED' is disabled.
100814 15:17:47 [ERROR] Can't open shared library '' (errno: 0 API version for STORAGE ENGINE plugin is too different)
100814 15:17:47 [Warning] Couldn't load plugin named 'PBXT' with soname ''.
100814 15:17:48  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /opt/lampp/var/mysql/ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
share|improve this question

Its a directory ownership issue.

chown mysql.mysql -R /opt/lampp/var/mysql

Should fix it.

The libpbxt error is because of a conflict between your system libraries and the ones bundled with XAMPP, but that is not fatal

share|improve this answer
Well, I changed the ownership and now the mysql server gets started. The problem now is that the user can't login. I receive Access denied. – jitendra Aug 14 '10 at 13:15
reset the password. why are you running xampp anyway why not run the packages supplied by ubuntu ? – topdog Aug 14 '10 at 13:33

My xampp installation on Ubuntu Lucid has the mysql ownership as nobody.root, or for some files root.root. So I don't think the above is correct. I think maybe the user is not aware that lampp executable (/opt/lampp/lampp start) must be executed as user root :

tomtom@bach:~$ sudo /opt/lampp/lampp start
Enter sudo password: <hidden input>[Enter]

and now lampp should launch the components of xampp.

xampp for me meant easy integration and meant examples and documentation. I like it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.