Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have tried to install cassandra on my Ubuntu test environment, but what happens when I try to start it is that I get the following error:

java.net.BindException: Address already in use

I have tried port 3072, 10032 and 8080 in the config, but it doesn't change. Still the same error.

So what can I do - can I free up the port number I want to use to let Cassandra take it?

Thanks

share|improve this question

1 Answer 1

up vote 2 down vote accepted

run netstat -ntlp to check what applications are using the ports then determine if you need them or not.

share|improve this answer
1  
You need to run netstat as root to get the processname with the -p option, but yeah, what topdog says, use netstat to identify the process and then decide if you need it on that port more than you need cassandra on that port, and if not, kill it. –  Jason Tan Aug 14 '10 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.