Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a virtual Windows Server 2008 machine that I am trying to FTP a file onto. When I enter ftp://[ipaddress] from my local machine, I can successfully login with my admin credentials. However, when I try to upload a file, I receive the following error:

An error occurred copying a file to the FTP Server. Make sure you have permission to put files on the server.

Details:
200 Type set to I.
227 Entering Passive Mode.
550 Access is denied.

I logged into the server and checked the firewall settings. The inbound rules has the FTP Server (FTP Traffic-In), FTP Server Passive (FTP Passive Traffic-In), and FTP Server Secure (FTP SSL Traffic-In) rules all enabled. Still I can not upload a file. In an effort to bypass this, I temporarily turned off the firewall. This did not work. I checked permissions on the directory and administrative users have full access. What am I doing wrong?

Thank you

share|improve this question

Do you have the FTP site permissions set to READ and WRITE? If not then that's the problem.

share|improve this answer

The issue is with the site privileges. However if all that is checked and you're certain, then you have to go into the basic settings option (right click your "sites") select "connect as" and change some stuff around. I'm not going to condone/stand against someone making a server less secure.

Happy Hunting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.