Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
OS: Ubuntu 10.04 Server
Postfix: 2.7.0

I run my own server and have been using it for email for years via SquirrelMail and Emacs. I had everything fairly locked down, with both IMAP and outgoing SMTP restricted to localhost only: SquirrelMail was secure because I only opened it up via https and it did everything locally; Emacs was secure because I had it set up to use SSH/port-forwarding to connect to SMTP & IMAP servers.

I recently bought an Android phone and I want to access email. I've opened up IMAPS on the firewall and configured Dovecot (1.2.9) properly and I can connect to it. I can't figure out what to do with Postfix, though; everything I try results in "Unable to open connection to the server". I'm trying to configure things via Webmin (1.510) as I don't really know much about Postfix or Dovecot (when I knew more about these things I used Sendmail and Courier, back in my RedHat days).

I believe I have TLS enabled in Postfix, but my Android client thinks that that means that port 587 should be used, but that port is not active (as verified by netstat -lntp output). Port 465 is, though, which again my Android client thinks means that SSL is enabled. I've opened up both ports in my firewall to no avail (and I've verified it with an external port scan).

My ultimate goal is to be able to send and receive email on my Android phone securely. I apologize for asking such a broad question, but I really rely on the email stuff to "just work", so I don't have much recent experience with this stuff, and next to no experience with Postfix.

Your time and help are appreciated!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Try following the Ubuntu Server Guide's chapter on Postfix.

Also the standard documentation of Postfix (especially the Basic Configuration and Standard Configuration Examples READMEs) is written quite well and understandable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.