Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

somethings wrong here - recently we just installed Sage the accounting package on our server. Sage on its own runs on pervasive SQL. SO it installed pervasive SQL as well in order to run. However once the installation was over - our server has an installation of apache2triad with mysql installed. Now I can't connect to mySQL for some weird reason I get the following error:

2003 Cant connect to MySQL on localhost 10061

I've disabled firewalls and checked the task manager it shows mysqld running in the background and mysql is running as a service in the services window but I still cannot connect. It was working perfectly fine before we installed the above mentioned software.

Help me please what should I do here?

share|improve this question
    
Maybe last installation overwrites old users and password. –  lg. Aug 16 '10 at 10:14

2 Answers 2

Your error message is a connection refused code so you are reaching MySql and I think maybe during the installation mysql has been ugraded (maybe not by the install itself but by the installer as it is common to update and upgrade before installing new things) and the my.cnf file restored to default (so if you connect from other machines, you have to change back the skip-networking or bind option). Also I would check if you user has permission to connect from % hosts.

share|improve this answer

AFAICT pervasive is a seperate product from MySQL so should not have touched any of the mysql nor php config files - but do check the timestamps on these.

You've already checked that mysqld is running - but do RTFM and check what port it is running on (and what port your php is trying to connect using). Note 10061 is an error code not the port number.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.