Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to install postfix and dovecot on my Debian server, but when I run apt-get install postfix, I get this error:

Err http://ftp2.de.debian.org etch/main ssl-cert 1.0.14 404 Not Found [IP: 195.71.68.86 80] Failed to fetch ssl-cert_1.0.14_all.deb 404 Not Found [IP: 195.71.68.86 80] E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Thoughts?

share|improve this question

2 Answers 2

As suggested in the message, this error is often caused by failing to run apt-get update.

As root, run:

apt-get update && apt-get install postfix
share|improve this answer
    
Tried this and got a number of failed to fetch errors, which leads me to believe that greenmang is probably right... –  dirknibleck Aug 18 '10 at 0:11

As you can see here [ http://ftp2.de.debian.org/debian/ ] "etch" is listed nowhere.

Whereas if you check [ http://archive.debian.org/debian-archive/debian/dists/ ] shows that "etch" has been moved to archives or old-stable.

So it is recommanded that you upgrade your distro to current stable i.e. Lenny.

The security support is also terminated to "etch"

[ http://www.debian.org/News/2010/20100121 ]

share|improve this answer
    
How do I go about upgrading a vps debian? Is there an apt package for that? –  dirknibleck Aug 18 '10 at 0:11
    
To upgrade from etch to lenny check following link debianadmin.com/… Just make sure that instead of replacing "etch" with "lenny", replace "etch" with "stable" That way you will always have stable branch of Debian and will never have to worry about etch / lenny / squeeze or whatever. This is what I follow on my servers. So for VPS Debian procedure shouldn't be different. –  greenmang0 Aug 18 '10 at 6:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.