Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It doesn't matter who I am logged in as I am getting the following error in the mmc console when I launch the firewall advanced settings

There was an error opening the Windows Firewall with Advanced Security snap in
You do not have the correct permissions to open the Windows Firewall with Advanced Security console, You must be a member of the Administrators group or the Network Operators group to perform this task. For more information, contact your system administrator. Error code: 0x5.

Ive tried processmonitor to identify what permission is being denied but no luck.

If I run netsh directly I get access denied as well.

This is running windows server 2008 SP2. And yes I was running as an administrator.

Any ideas?

share|improve this question

1 Answer 1

What OS? Are you under an Administrator account ?

may be a malware that have disabled access to firewall settings, you could try to scan your PC with an anti-malware like MalwareBytes.

share|improve this answer
    
Added to the question w2k8 SP2 and yes was an admin –  Simon Sabin Aug 17 '10 at 12:38
    
this : winvistaclub.com/t61.html maybe can help you –  aleroot Aug 17 '10 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.