Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to limit the cpu usage of an legacy Clipper application vía WSRM (Windows System Resource Manager). The app hogs the CPU to 100% usage, then I tried with:

  • Installing WSRM
  • Creating a new Process Matching Criteria (TestProc), including the files C:\WINDOWS\SYSTEM32\CMD.EXE, C:\WINDOWS\SYSTEM32\NTVDM.EXE, C:\TEST\TL_BLI.EXE (the damn 16-bit program). I tried adding the programs manually and selecting by "Running Process" and "Application"
  • Adding the group "Everyone" to the criteria
  • Creating a new Resource Allocation Policy (TestPolicy), adding the TestProc criteria, and setting the CPU to 20%
  • Setting the WSRM Management state to "Running"
  • Setting the WSRM Management type to "Manage"
  • Setting the WSRM Current resource allocation policy to "TestPolicy"
  • Restarting WSRM

But no luck, the process (C:\TEST\TL_BLI.EXE) continues to run "in the wild" to 100 % CPU, running locally or via Remote Desktop.

Any ideas?

share|improve this question

1 Answer 1

On NT 4.0 or higher, increasing the Idle Sensitivity will decrease the CPU usage of a 16-bit process. The Idle Sensitivity can be set under the properties of the 16-bit executable Misc tab.

share|improve this answer
    
thanks, I tried with "Idle sensitivity" to High and the app runs better now (30% CPU with peaks of 80%). But it works only if I'm using the application vía the desktop shortcut, and I was looking for a way to enforce any application to behave. –  user41235 Aug 17 '10 at 13:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.