Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running FreeBSD and I started an instance of php-fpm. After that, every command I type (except kill and cd) just return "Abort". Last time this happened host said I had a memory leak, probably caused by php-fpm, I'm assuming. Any way to fix this?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Sounds like the first part is to reboot. Secondly, find your memory leak OR, when the server comes back up, try the previous steps while having some sort of top session going to see if after starting the php-fpm module things go awry.

Memory leaks suck :(

share|improve this answer
    
+1, "Memory leaks suck" @blockhead, Looks like it actively developed. If it's version matched for your php install you might want to contact the php-fpm team to see if they're aware of any problems. –  Chris S Aug 17 '10 at 19:31

PHP-FPM has special option to avoid memory leaks

max_requests - How much requests each process should execute before respawn. 
               Useful to work around memory leaks in 3rd party libraries.
               For endless request processing please specify 0. 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.