Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hi i have an svn server in apache 2.2 my svn client is tortoise svn. all was fine for months. i don't see something special in logs when problem started happening today.

suddenly svn clients for all users are hanging. which means i run some svn command like svn log http:/....svnurl... and it just hangs. I watched the access.log of apache and i see this i think this says something

192.168.1.100 - myuser [17/Aug/2010:21:54:21 +0300] "OPTIONS /svn/repos HTTP/1.1" 500 539 192.168.1.101 - - [17/Aug/2010:22:18:53 +0300] "OPTIONS /svn/repos/trunk/myurl HTTP/1.1" 401 401

however when i watch the communication with ethereal i see like i do get response i see:

`Authorization: Basic shfksjdfhjhf=

?xml version="1.0" encoding="utf-8"?D:options xmlns:D="DAV:"D:activity-collection-set//D:options`

so it looks like im getting response isnt it?

anyone has any idea what is happening? why are all svn clients stuck?

Thanks

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

No, the responses you're sending are error codes: 500 Internal Server Error and 401 Unauthorized on the two responses you sent back.

You might try restarting your apache server and make sure that you've got free disk space and check your logs for other errors.

share|improve this answer
    
I have 10GB free on drive C where the svn is I have already tried restarting the apache server and also the server itself. I had problems in he past with not enough free disk space, but isn't this disk space enough? or maybe I should look into another parameter to know if i have enough disk space? –  Tomer Aug 17 '10 at 19:37
    
i think i just got an error message about disk full althouggh I had 10G maybe was used by swap or something i'm checking i'll get back to you soon... –  Tomer Aug 17 '10 at 19:41
    
i just freed up another 5GB of disk space still same error. –  Tomer Aug 17 '10 at 19:46
    
now all my access.log file shows is just this and i have the same problem still! 192.168.1.1 - - [17/Aug/2010:22:49:52 +0300] "OPTIONS /svn/repos/trunk/aaa HTTP/1.1" 401 401 192.168.1.2 - - [17/Aug/2010:22:49:52 +0300] "OPTIONS /svn/repos/trunk/bbb HTTP/1.1" 401 401 192.168.1.3 - - [17/Aug/2010:22:49:55 +0300] "OPTIONS /svn/repos/trunk/bbbb HTTP/1.1" 401 401 192.168.1.4 - - [17/Aug/2010:22:50:04 +0300] "OPTIONS /svn/repos/Branches/dddd HTTP/1.1" 401 401 192.168.1.5 - - [17/Aug/2010:22:50:20 +0300] "OPTIONS /svn/repos/Branches/ddddd HTTP/1.1" 401 401 –  Tomer Aug 17 '10 at 19:52
    
still have the same problem, anyone knows what to do? thanks –  Tomer Aug 17 '10 at 20:33
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.