Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Windows 7 on my Desktops that are connecting to the office AD Domain, and we connect to a remote set of servers that are on their own AD Domain. Remote Desktop refuses to save our credentials. My Boss want to be able to save his connection settings to a folder like he did in previous version for quickly connecting to the servers. Server 2008 seems to not correctly support this. If i look at the logs it looks like the client is sending the computer name as the user name and not what is saved.

Does anyone know how to enable the saving of the credentials in these version of Windows and RDC?

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

One quick and easy way to get this working is to use Remote Desktop Connection Manager.

It's an awesome utility. Save credentials. Handles resolution automatically. Makes for easy access to multiple servers. Makes my life sooooooooo much easier :-)

share|improve this answer
    
Very nice. I remember seeing that in windows before, and never really used it. I will suggest this so far it works well for me. –  Travis Aug 18 '10 at 15:35
add comment

I remember there is one setting on the RDS server that says always prompt for password, another setting to disallow saving password. it's either in RDS host configuration or GPO.

share|improve this answer
add comment

Use Terminals.
It allows you to have tabbed RDP sessions and you can tag your servers to they are organized.

share|improve this answer
add comment

Start mstsc, put in the server ip address or name, put in the username in the form domain\username (where domain is either the AD domain or the local machine), click the Options button, check the box that reads "allow me to save credentials", click the Save as button, save it with whatever name you want to where ever you want, click the Connect button, type the password and select the box that reads "remember my credentials". Bada bing, you've just saved that connection with your credentials and need only to double click it in the future to automatically connect and log in.

share|improve this answer
add comment

It sounds like a GPO or possibly even a local policy, affecting the target machines, causing them to ignore credentials saved on the client. If this is the case it won't matter what RDP client you use, you will still be prompted for at least your password.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.