Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Our company has a main mail server. An exchange sits in our office which pulls mails from mail server. we use outlook to connect to our office exchange server and send/receive emails.

Now, the problem is, the exchange server is not leaving a copy on our main mail server. It is just pulling all mails in the mail server and storing locally.

Is there any way to set at exchange/mailbox level to restrict the exchange server to leave a copy of message on the main mail server?

share|improve this question
3  
This setup seems like an incredible waste of resources. Why is it set up this way? –  GregD Aug 18 '10 at 15:27
    
Yeah that's true.Even, I got confused with this setup when I look at it for the first time few days back. Is there a way to resolve the issue?? –  user51585 Aug 18 '10 at 15:30
1  
Can you be more specific about the protocol being used to communicate, I like others have had to assume based on the limited detail in your question. –  john Aug 10 '13 at 9:23
add comment

4 Answers 4

If you had the mail server forward mail to the exchange server rather then the exchange server fetch the mail. Then a copy would always be on the server. That's a work around if exchange server doesn't allow leaving a copy on the mail server.

share|improve this answer
    
I am afraid, the exchange server is pulling mails from mail server. Not sure which option to set on the exchange server to keep a copy on the mail server. –  user51585 Aug 18 '10 at 15:46
add comment

I've had to use this before for a client running SBS 2003. The company mail was hosted (POP3) but they wanted other features of Exchange. In my case I used Microsoft's Exchange Connector for POP3 Mailboxes. It was, um, somewhat evil.

There are quite a few tools to use to get Exchange to retrieve (pull) mail from an external source (I'm assuming POP3 in your case) and deliver to internal mailboxes. Which one are you using? You'll need to configure the tool you're using in Exchange to leave the mail on the remote server. Keep in mind that it's possible the tool you're using doesn't support that option.

share|improve this answer
add comment

It sounds like you are using a POP3 connector. In my opinion, the behavior you are seeing is perfectly normal. I use a similar setup here for my Exchange 2007 configuration. Its not SBS, so I use a 3rd party connector to connect to the POP3 mailboxes. The mail is downloaded to the Exchange mailbox, and removed from the POP3 mailbox. Its nice to know that if our internal system goes down, we can still do business via POP3 if necessary, and the mail is still being delivered.

My question is, do you need mail to stay on the first server? If so, you will need to adjust the settings of the connector to leave mail on the server after download.

share|improve this answer
    
Hi Dan!! Thanks for you reply. Yes, I need to stay email on my first server. –  user51585 Aug 18 '10 at 16:26
    
What is the OS on the Exchange server? Is it SBS? –  DanBig Aug 18 '10 at 16:39
add comment

Bit of a long shot, but I've seen this happen at an individual mailbox level, where Outlook has been incorrectly configured to deliver emails to a PST file instead of an OST file.

Double-check the mailbox options in Outlook under the Data Files tab and see what's set up there. If there is a PST file configured as the default delivery location, you'll need to set up an OST file, then use the File > Import/Export tool to restore the data back to the mailbox.

share|improve this answer
    
This has absolutely nothing to do with client application behavior. –  mfinni Sep 9 '13 at 16:59
    
Whoops.... Misread the question :( –  john Sep 10 '13 at 17:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.