Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't get USB devices other than the mouse and keyboard to work in Windows under VMware.

I have Ubuntu Intrepid as my host operating system, and Windows XP Service Pack 2 as the guest operating system. I'm using VMware Server 2.0 for Linux.

Ubuntu and several other distributions have dropped /proc/bus/usb in favour of using something else. VMware has not updated VMWare Server to use the new usb path, and have a workaround listed here:

VMware Support: Mount /proc/bus/usb manually

Even with that workaround, my guest Windows OS still doesn't detect any USB devices that are working fine in Linux.

Does anyone have an idea of what else might be the problem?

share|improve this question
    
i had this same problem; even stranger, i got it working once, but after some VM reinstalls i couldn't repeat it. the host and VMWare software weren't reinstalled in any way, just the guests –  Javier Jun 1 '09 at 21:25

1 Answer 1

up vote 2 down vote accepted

I had issues setting this up with Ubuntu Server 8.04 as well. The answer lay in this Ubuntu Launchpad entry. It turns out VMWare are using a very old method of scanning for USB devices. In Ubuntu this can be reenabled by editing /etc/init.d/mountdevsubfs.sh and uncommenting the following:

#
# Magic to make /proc/bus/usb work
#
mkdir -p /dev/bus/usb/.usbfs
domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
ln -s .usbfs/devices /dev/bus/usb/devices
mount --rbind /dev/bus/usb /proc/bus/usb

After rebooting the VMWare web console successfully detected the USB devices. What you should see when logged into the VMWare Server web console is a small USB icon in the top menu on the far right. It is then a case of selecting your Windows VM, going up to the dropdown and selecting the USB device you want to attach to that VM.

  • Make sure you have added the USB controller virtual hardware device to the Windows VM.
  • I have not tested this with Intrepid, but it works fine with the latest release of Hardy (8.04LTS).
share|improve this answer
    
Yeah the old VMware would simply pass through any USB device you had connected, so I didn't know you had to explicitly enable each device. –  Neil Jun 2 '09 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.