Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an ubuntu server which I installed ubuntu-dekstop upon.

Then i started the Gnome Desktop with "startx" command.

I wonder:

  1. how do I kill Gnome so I can go back to only CLI?

  2. how do i disable Gnome form starting when Ubuntu server starts?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

You have 2 alternatives for the "kill gnome" part.

  • Since Ubuntu disabled the ctrl+alt+backspace combination, all you have to do is re-enable the combination
  • Or you can use alt+sysrq+K, this magic sysrq key combination kills all X programs.

To prevent Gnome starting on the startup, use update-rc.d to remove gdm.

# update-rc.d gdm remove
share|improve this answer
add comment

To get out of Gnome, click on the power-button-shaped icon (a circle with a vertical bar near the top) near the right of the top menu bar and select “Log Out”.

If you want to disable the graphical login manager, either uninstall the gdm package or arrange for the gdm service not to start by commenting out the start (...) paragraph in /etc/init/gdm.conf.

share|improve this answer
add comment

You can switch back to a console using the Ctrl Alt F1 keystroke where "F1" could be any number (often F1-F6) that represents the virtual consoles that are enabled on your system. You can use F7 or F9 to return to X depending on which one your system uses.

Beware of the magic sysrq. There are some dangerous key combinations such as immediate reboot.

share|improve this answer
    
@Gilles: Thanks. Fixed. –  Dennis Williamson Aug 19 '10 at 6:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.