Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When trying to backup the system state to shared drive the backup fails. This share is a samba share. The samba server is not on AD but I mapped a network drive so the credentials would be saved (Can't actually backup to the network drive, wbamin prevents that). When I run the backup over it fails. Both the log files mentioned in the output below are empty. Any ideas?

PS C:\Users\Administrator> wbadmin start systemstatebackup -backuptarget:\\ny-back01\backups
wbadmin 1.0 - Backup command-line tool
(C) Copyright 2004 Microsoft Corp.

Starting to back up the system state [8/19/2010 1:41 PM]...
Retrieving volume information...
This will back up the system state from volume(s) System Reserved (100.00 MB),Local Disk(C:) to \\ny-back01\backups.
Do you want to start the backup operation?
[Y] Yes [N] No Y

Creating a shadow copy of the volumes specified for backup...
Please wait while system state files to back up are identified.
This might take several minutes...
Found (118) files.
Found (10194) files.
Found (14481) files.
Found (31086) files.
Found (36456) files.
Found (48828) files.
Found (69057) files.
Found (73761) files.
Summary of the backup operation:
------------------

The backup of the system state failed [8/19/2010 1:43 PM].
Log of files successfully backed up:
C:\Windows\Logs\WindowsServerBackup\Backup-19-08-2010_13-42-09.log

Log of files for which backup failed:
C:\Windows\Logs\WindowsServerBackup\Backup_Error-19-08-2010_13-42-09.log

The operation ended before completion.
The version does not support this version of the file format.
PS C:\Users\Administrator>
share|improve this question

1 Answer 1

up vote 3 down vote accepted

The default allocation method for *nix OS's (of allocating disk blocks only when they're needed) is throwing Windows Backup for a loop. You need to pre-allocate the space.

Add the strict allocate = yes to your smb.conf and give it a shot again. (See http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html for details about the strict allocate option.)

I'm seeing some rumblings that indicate that turning on strict allocate, however, can make some Windows clients "time out" when asking to allocate very large files... Lovely. Trading one problem for another. Your mileage may vary.

share|improve this answer
1  
Heh, beat me by 10 seconds :-) –  Kyle Brandt Aug 19 '10 at 14:25
    
@Kyle Brandt: I was on the phone, otherwise I'd have been faster... >smile< –  Evan Anderson Aug 19 '10 at 14:28
    
Come on man, that's what headsets are for! You mean to say you can't talk to a client and throw down answers at the same time?? Sheesh, where's yer priorities?... :) –  squillman Aug 19 '10 at 15:40
    
@squillman: Heh heh... Much as I might want it to, Server Fault and I haven't found a mutually acceptable way to make money together... >smile< –  Evan Anderson Aug 19 '10 at 16:42
    
Heh @Kyle found a way :) –  squillman Aug 19 '10 at 17:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.