Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I tried running the latest code and went as far back as 0.6.07 and I keep getting the following error message when running duplicity. Any ideas how to fix? Tell me I dont have to upgrade to Python 2.4

[root@sierra duplicity]# duplicity
Traceback (most recent call last):
File "/usr/bin/duplicity", line 42, in ?
    from duplicity import commandline
File "/usr/lib64/python2.3/site-packages/duplicity/commandline.py", line 147, in ?
    class DupOption(optparse.Option):
File "/usr/lib64/python2.3/site-packages/duplicity/commandline.py", line 157, in DupOption
    ALWAYS_TYPED_ACTIONS = optparse.Option.ALWAYS_TYPED_ACTIONS + ("extend",)
    AttributeError: class Option has no attribute 'ALWAYS_TYPED_ACTIONS'
share|improve this question

1 Answer 1

up vote 0 down vote accepted

It looks like ALWAYS_TYPED_ACTIONS is was added either in Python 2.4 or 2.5, so you'll have to go back to before duplicity used it. Going back to 0.5.x should be enough.

You could report a bug to the duplicity maintainers, since their web page says that Python 2.3 is supported. However they may just fix the issue by amending their requirements to 2.5.

share|improve this answer
    
yea i opened a "ticket" but have yet to hear from anyone. –  luckytaxi Aug 19 '10 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.